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Welcome to Xandros Server

Thank you for choosing Xandros Server.

Use this document to understand, install, start, and configure Xandros Server.
For information on using the server components, see the Xandros
Management Console Administrator Guide.

What is Xandros Server

Xandros Server is a Linux operating system and suite of software to configure
and manage servers and resources. You can back up user computers, establish
Web sites, file servers, virtual private networks, and manage user accounts
and printing, for example.

Xandros Server can be used in new or existing networks. It can be integrated
into networks with Dynamic Host Configuration Protocol (DHCP) and
Domain Name System (DNS) servers already running. It can install into
existing Windows or UNIX networks, and in UNIX-only environments, for
example. Xandros Server combines an array of Linux-based server facilities
with a graphical user interface similar to that in Windows Server 2000 and
2003 products. Xandros Server can be integrated into Microsoft Outlook
environments for coordinated meeting scheduling, for example. It is
compatible with your existing Windows domain and networking
infrastructure, offering you a low cost, plug-and-play alternative to costly
Windows servers.
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Standard and Advanced editions are available. The Advanced edition includes
more functions, such as clustering/load balancing, as well as the ability to
deploy Xandros products to computers over the network and manage those
computers by incorporating Xandros BridgeWays - Deployment and
Management Edition components.

Features of Xandros Server

Some features of Xandros Server include:

¢ Easy installation

* Optional use of graphical user interface

* User-friendly wizards

* Ability to coexist with a Windows networking environment

¢ Xandros Management Console (xMC), a remote Microsoft Management
Console (MMC)-like administration tool

¢ Comprehensive set of server components; add or remove components to
suit your needs

* Set up Web sites, wiki sites, blog sites, time servers, file transfer protocol
(FTP) sites, file servers, print servers, virtual private networks,
streaming-media servers, and proxy servers, just to name a few examples

¢ Use Scalix Xandros Edition to manage meetings, tasks, distribution lists,
and addresses among multiple users with existing applications, including
Microsoft Outlook

¢ Access e-mail and calendars anywhere with a Web browser

¢ Back up user data, including Windows computers, to disk or tape

* Create certificates and use encryption for secure Web site transactions

¢ Create network user accounts for Linux, UNIX, and Windows computers
¢ Create multiple administrator accounts with different levels of privileges

¢ System monitor alerts administrators of critical events and minimizes
downtime

* Integrated firewall

¢ Access the interface on a Windows computer

¢ Support for redundant array of independent disks (RAID)
¢ Support for 32 and 64-bit processors

¢ Support for symmetric multiprocessing (SMP), which means that multiple
processors can be used in a computer to do more work and balance load

* Runs popular server applications, including JBoss, IBM WebSphere, IBM
DB2, Oracle, Sun One J2EE, MySQL, LAMP, and others

¢ Plug-in architecture means components can be developed by third parties
¢ Compliant with the Linux Standard Base (LSB)

N
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Xandros Server package

As outlined in the table, several CDs can be included.

(1)

Includes

Installation CD

32 or 64-bit version

Applications CD 1

xMC for Windows

BRU backup agent for Windows and Macintosh
computers

Windows Migration Tool

Scalix Outlook connector

IBM DB2 Express C Edition

MySQL

Oracle 10G Express Edition

Applications CD 2

Xandros Management Console Administrator Guide
Scalix Xandros Edition

Scalix Evolution connector

Adobe Reader

IBM Websphere Server

JBoss Application Server

NoMachine NX Enterprise Server

SugarCRM

Sun Java Runtime Environment

BRU and Scalix documentation

Applications CD 3
(for 64-bit version)

Adobe Reader

IBM DB2 Express C Edition
MySQL

Sun Java Runtime Environment

Xandros Desktop
Installation CD

Included with Advanced edition

When you install Xandros Server you install Xandros OS as the operating
system, a suite of desktop applications, and the server software. Desktop
applications include a Web browser, e-mail client, system tools, and utilities.
They include applications developed by Xandros, third-party applications, and
open-source software made available by developers around the world.

Xandros provides two methods to obtain more software. First, Applications
CDs are provided. Simply insert the CD into a drive to install from it. Second,
more software can be installed from Xandros Networks, which is an
application that accesses servers over the Internet so that you can download
security updates, application updates, and new software, such as
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OpenOffice.org. You update Xandros Server with Xandros Networks, and you
can purchase additional server components, licenses, and other applications.

Purpose of this guide

This document provides information to understand Xandros Server, install it,
access the desktop and applications, and configure Xandros Server. It is
intended for network administrators, for example administrators of Windows
servers who may or may not have Linux experience.

Documentation conventions

The following conventions relate to using the mouse.

When you see this... Do this...

Click Press the primary mouse button (usually the
left mouse button)

Double-click Quickly press the primary mouse button
twice
Right-click Press the secondary mouse button (usually

the right mouse button)

Click File » New Click the File menu, and select the New
option in the menu

Enable the Network check  Click the check box beside Network to place

box an x or check mark inside the box
Right-click and select Press the right mouse button, and select the
Paste Paste command in the submenu that appears

The following conventions relate to keyboard actions.

When you see this... Do this...

Press Enter Press the Enter key on your keyboard

Press Ctrl+Shift Press ‘Ehe Ctrl key and the Shift key at the
same time

Type mkdir Type the text mkdir using the keyboard; also

indicates programming code
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The following conventions relate to icons in this document.

When you see this...

It means this...

A

Caution — Negative consequences to software,
hardware, or files can occur

Tip — Usually presents an alternate way to
perform a task

(1)

Note — Provides additional information

There is usually more than one way to perform a task. For example, you can
click a tool bar button, select a menu item, or right-click and select a menu

item.

Learning how to use Xandros Server

The table lists resources available.

Documentation

Explanation

Getting Started Guide

Provides information to understand, install,
start, and configure Xandros Server (this
document)

Xandros Management

Explains the server components and how to use

Console Administrator  them

Guide

Online help Provides instructions for using the product;
excludes installation and configuration
instructions

Quick Start Guide Provides an introduction to the product

To access the Administrator Guide

| Install it and Adobe Reader from Applications CD 2.

1 Access it by clicking Launch » Applications » Server Management »
Xandros Management Console Administrator Guide.

To access help within server components
* Click the Help button on the tool bar or press F1. ?
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To access help within other applications
* Click Help and select the appropriate option.

To access help for all applications
* Click Launch » Help.

To access the Quick Start Guide
¢ On the desktop, double-click the Quick Start Guide icon.

Getting technical support

The table lists resources available.

Help Description

User forums http:/forums.xandros.com

Technical support Free installation support by e-mail to registered
users for 90 days.
Register at www.xandros.com/support/register.html
Contact support at support@xandros.com
For better service, send a separate e-mail for each
question.
For support beyond the 90-day period, packages can
be purchased. See www.xandros.com/products/
business/server/support.html

You can also access the Hardware Detection panel in the Control Center, click
the Tech Support button, and provide the file generated to Xandros Technical
Support.

Determining version numbers

You may need to know the version number for technical support or when
downloading software.

To view the Xandros Server version number

| Click Launch » Xandros File Manager.

1 Click Help » About Xandros OS.

To view the Linux kernel version number

| Click Launch » Control Center » Control Center.
1 The Linux kernel version is displayed as the Release.
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To view the software version number in an application
¢ In the application, click Help » About...

You can also view version numbers in Xandros Networks by
clicking Settings and enabling the Expert View option.

You can also view product, build, and serial number information
in the Hardware Detection panel of the Control Center.
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Overview

This chapter provides an overview of Xandros Server, including:
¢ Managed Community

¢ Xandros Management Console (xMC)

¢ Custom server components

* Integrated backup facilities

* Integrated mail and calendaring services

Managed Community

Xandros provides a powerful “Managed Community” model that automates
many tasks and presents a simplified, centralized approach to administering a
multi-server environment. The services you implement within the Managed
Community are aware of each others’ presence, so administrative tasks that
span multiple services on multiple servers can be achieved in a convenient
manner.

A Managed Community is one or more Xandros computers in a domain.
Xandros Server and Xandros Desktop computers can comprise a Managed
Community. In each Managed Community there is one controlling computer
called a Community Management Server. It maintains network user accounts,
for example, for the entire domain. Any additional server installations are
referred to as Member Servers. One of them can be designated as a failover
installation for the Community Management Server.
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Each Managed Community can have its own domain, meaning it is not
installed into an existing domain.

Designating a Community Management Server

When setting up a Managed Community, you first designate a Community
Management Server.

Community
Management
Server

N

Xandros OS

Managed Community has one Community Management Server

Each Managed Community has one Community Management Server. For
Xandros Server, within your corporate local area network (LAN) you can have
one Community Management Server and several Member Servers that
provide backup, networking, file, print, Domain Name System (DNS), and
other internal services. You might set up a second Managed Community in
your Internet-accessible secure zone, again with a Community Management
Server, plus additional Member Servers for Web, file transfer protocol (FTP),
e-mail, and DNS services.

In a larger enterprise you may decide to deploy a large number of servers for
various services within your Managed Community while employing a single
Community Management Server, even when the servers are housed in
diverse locations. Or you can set up separate Managed Communities for
various corporate divisions or geographic locales, each with one Community
Management Server and any number of additional servers. The choice is
yours, as Xandros provides such flexibility.
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Grouping servers

You can set up virtual groups of servers within your community to simplify
administration. For example, you name separate groups for all your file or
Web servers, or for all the servers in your London office, to make it easy to
monitor and manage related server activities. Because these are virtual
groupings, a particular server can reside in more than one group. For
example, the Web servers in your London office can reside in both the “Web”
and “London” groups. The figure here shows that file, proxy, and Web servers
have been grouped into their own categories. Grouping servers makes it easy
to manage them.

= &% Managed Community ~|| Name + Description
= Management Licenses &) All Computers All Computers
e g} FILE SERVERS Ottawa
Al Computers g PROXY SERVERS  Ottawa
g FILE SERVERS UJ: WEB SERVERS Ottawa

Ug PROXY SERVERS
U WEB SERVERS

Grouping servers for easy management

Centralized network account management

Your Managed Community provides a centralized repository for network
accounts to simplify account administration and allow all authentication to
occur in a single place. For example, rather than set up separate user accounts
on the file, Web, FTP, print, virtual private network (VPN), and other servers
within your Managed Community, you manage a single set of network
accounts, providing users with access to a range of services on various
servers. So when an employee joins or leaves your company, it becomes a
simple task to establish or discontinue access to network services.

Thanks to the centralized account repository, a user logged in to a Windows
computer using their domain account does not have to provide their user
name and password to access certain services within the Managed
Community, such as a Web site with protected services using NTLM
authentication.
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Work flow automation

Because the servers within the Managed Community, as well as the services
on a particular server, are aware of each other’s presence, many normally
discreet system administration tasks can be automated, to save you the
trouble of laborious manual configuration. For example, when you add a
virtual Web server, the wizard prompts you to automatically generate the
required DNS entries, provided that you have DNS administrative privileges.
Then Xandros Server checks to see if there is a managed firewall on your Web
Server and, if you have administrative privileges for the firewall, opens the
appropriate ports.

DNS
http://www.xandros.com

Community
Management Server

Automatic generation of DNS and firewall entries within your Managed Community

Other tasks within your Managed Community are automated in a similar
manner. For example, when you add a network user account, entries for Web,
file, print, VPN, FTP, and proxy server authentication are generated
automatically.

12 Xandros Server Getting Started Guide: Chapter 2



Xandros Management Console (xMC)

Linux servers are renown for their power and stability, yet their installation
and administration generally requires technical skill and command-line
experience. Xandros greatly simplifies these tasks by incorporating the power
of Linux into the all-graphical Xandros Management Console (xMC).

©C =Y

File Wiew Tasks Bookmarks Windows Help

Computer name: |_ﬂL xanserverl ottawaxandros.ca |vH Select...

@Managed Community - ;

S} "I xanserverl.ottawa.xandrd Xandros Managemer_lt Cons ¥
Local Accounts |
&G Network Accounts f
» BRU Backup Server - <
[Slcertificate Manager Server Status | Statistics

glzoHCP Server

RYONS Server Service | Uptime (day:hr:min)
@ Event Viewer @ BRU Backup Server Not running
@ File Server @ DHCP Server Not running

@ DNS Server Mot running

SiFirewall
[IFTP Server
£ Helix Server

+/ File Server: Windows 00:00:35

@ File Server: UNIX (NFS) Mot running
@ Firewall Mot running
@ FTP Server Mot running

[l Performance Monitor L
& Print Server
34 Proxy Server
ZlRemote xMC Service \ L
HRouting v
§SsH server =
d4 Storage Manager

‘ E g

xMC showing administrator access to services in Xandros Server

Xandros Management Console has multiple features. Because it is a remote
management tool, you do not need to be at the server computer to manage its
services. xMC employs a plug-in architecture so you can develop your own
server components to manage server software from within xMC as well. The
plug-in architecture also means that you can add and remove server
components to meet your needs. xMC can be run remotely on other
computers, such as Windows and Xandros Desktop. Effectively, xMC
becomes your all-in-one management console on Xandros services.

Likewise, you can log into multiple Managed Communities from a single
workstation. When you log into xMC, you are logging into the Managed
Community you designate, and from there you can switch to any Xandros
server or Xandros desktop in that community that you have permission to
manage.

Due to the flexible, plug-in approach, you can add or delete components from
xMC to suit your needs.

The left pane of xXMC presents a convenient tree view of the services you are
authorized to access and manage for the selected server. It also provides
access to various administrative tasks, such as managing user and network
accounts, setting system alerts, and configuring event reports.
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When you click on various server services, notice that they present a
consistent tabbed interface with global controls, tool bar buttons, and menu
items that adapt to the task at hand. Informative messages automatically
appear when tasks must be performed prior to starting a service. For
example, the DHCP Server component prompts you to configure a DHCP
network connection if you have not done so yet, and the FTP Server
component prompts you to launch the wizard to set up your first site.

é The FTP server does not have any sites. To create a
site, launch the New Site wizard.

Launch Wizard...

FTP Server prompts you to launch the wizard to set up your first site

The services and administrative tasks displayed in xMC automatically adapt
to your administrative privileges. For example, as the xMC Administrator for
a Web server you may be granted access to certificate, FTP, proxy, and Web
services, as well as to the Event Viewer.

File Wiew Tasks Bookmarks Windows Help

Computer name: |_ﬂ£ xanserverl ottawaxandros ca|

OE %

"l xanserverl.ottawa xandros.{
[Slcertificate Manager

Server Status Statistics

(‘é:\:z;tal\‘/\ewer Service Uptime (day:hr:min)

[{IFTP Server @Firewall Mot running
ft/Performance Monitor @FTP Server Not running

S Proxy Server @ Proxy Server Not running

) Web Server @ web server Not running

B Computer Management

Components a typical Web administrator may see in Xandros Management Console
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User-friendly wizards

Xandros eliminates the pain of manual commands. Instead, wizards are
available for many tasks, and they are especially powerful because they know
which service privileges you have within the Managed Community.

For example, when you click the Create Site button on the Web Server tool
bar, it launches a wizard to help you to configure the site with default settings,
using an existing site as a template, or by loading an existing Apache
configuration file.

Create Web Site Wizard

W This wizard allows you to easily configure a new Web site,

Please select how you would like to create your new site.
@‘Start with default settingsé
) Use another site on this server as template

() Load frem an existing Apache Web Server configuration file

Create Web Site wizard guides you along various paths to set up a site

The wizard fills in default settings automatically, which you can accept or
change. Because it is aware of DNS servers within your Managed Community,
it prompts you to select from the available DNS zones if you have DNS Server
privileges.

When you add a local user, another wizard automatically assigns the account
to your standard set of groups. Advanced options let you easily customize
everything from the login shell to server groups.
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Viewing system events

The Event Viewer provides a single point of access to all of your system logs,
giving you a view of all activity on your current server, making it easy to focus
on areas of concern, such as system alerts or signs of attempts at
unauthorized access.

To create a custom report, a check list is provided to select particular logs
(such as the firewall log to detect unauthorized access), and then filter the
events according to various criteria (such as the time period or severity).

Eile View Tasks Bookmarks Windows Help

Computer name: [_Elxansewsrl,uttawa,xandms,ca ‘v][ Select..J
«-t 2 O0EBERIRET & ? B
4@ Managed Community |~ /| Name: ISSH Server Events ]

= § xanserverl.ottawa.xandros.

Comment:
&1 Computer Management 0l IAII events logged by the SSH Server component ]

[@ Local Accounts Report Content | Sources | Filters
G Network Accounts
» BRU Backup Server Report: SSH Server Events, Created: 03/26/2007 11:54:55 am

[Slcertificate Manager

“DHCP S ‘Date - ‘ Facility | Priority ‘ Source | Message
gDNS SE:::? 03/26/2... auth info sshd Server listening on 0.0.0.0 port 2
E QEvsnt Viewer 03/26/2... auth info sshd Received signal 15; terminating.
Iy ﬁ.Repurt; 03/26/2... auth info sshd Server listening on 0.0.0.0 port 2
9, Settings
(@ File Server
i Firewall

[{IFTP Server

Event Viewer showing report

System monitoring and alerts

Xandros provides integrated system monitoring and alert facilities to help
keep the servers in your Managed Community running smoothly, and it
allows you to take action before a problem occurs.

The System Monitor helps you to maintain a high level of service availability
and lets you set up alerts, such as notification when a disk nears capacity,
heavy CPU load or RAM usage, or a hot CPU. You can then tell the system
what action to take.

& Notification from computer
xanserver2.ottawa.xandros.ca at
04/27/2007 02:53:27 pm (System Monitor
Notification):

The proxy server has stopped.

Alert that proxy server has stopped
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Name: [Fils Server at 85 percent ]
Description: [Alsrt to archive old files ]
Type: [Disk Usage ‘v]
Mount Point: [,t ‘V]
Threshold:

Creating a disk monitoring alert in the System Monitor

For example, you can monitor your File Server and have it alert you by e-mail
when disk usage reaches 85 percent of capacity. Or, with another alert it can
run a program to archive the oldest files representing 30 percent of the drive
capacity, to automatically restore File Server usage to 60 percent.

S 05
Name: [Fils Server e-mail alert ]
Description: [Fils Server at 85 percent ]
Type: |E—mai| ‘v‘
Recipient: [Janer@xandros.com ]
Subject: IFI|E Server at 85 percent ]
Message: The Xandros File Server has
reached 85 percent of capacity.
Run archive smpd.

Specifying the action to take when disk capacity threshold reached

You can instruct the System Monitor to check the logs in your Managed
Community, send alerts, and take action based on log priority. There are
several priority levels, including critical errors and emergencies.

S o B
Name: [Wat(h for critical events l
Description: [System critical l
Type: [Log Event |vl
Log source: | System Logs |vl
[] Keyword: [ l
[%| Severity: () Discrete @ Cumulative
- Emergency
Al v
(- Critical <
- Error
- Warning
- Notice
- Info
- Debug

Creating an alert in the System Monitor based on errors logged
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Managing logical volumes

The Storage Manager in xXMC supports Logical Volume Management (LVM),
which makes it easy to expand storage facilities to meet growing system
needs.

Logical volumes are an alternative to partitions and allow you to combine
multiple hard disks into a single volume group. Normally, when you set up
services with primary and extended partitions, one of the most difficult tasks
is to estimate storage requirements based on anticipated usage. Thanks to the
logical volume management in the Storage Manager, you can “combine”
multiple disks into one single volume group, so the volume group can then
contain data surpassing the size of an individual drive. With xMC’s powerful
remote management, you can even do it remotely after a new hard disk is
installed by your support staff.

Adding a disk to your server

Migrating Windows users to Linux

To migrate domain user accounts from Windows to Linux, Xandros provides a
tool to run on your Windows Server. Located on Applications CD 1, the
Windows Migration Tool captures the information, and then asks you where
you want to save the file. You then import the file into XMC and the accounts
from your Windows domain are added to your Network Accounts.

Export
[9' I’OII User Accounts
|

Import
User Accounts

H—»

Migrating user accounts from Windows to Linux
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Adding or removing components

xMC makes quick work of adding or removing components for any of the
servers in your Managed Community. You simply select the server and then
launch the wizard to connect to the repository on Xandros Networks, from
which it creates a list of available components. You then check or uncheck the

components you want to add or remove and allow the wizard to complete the
tasks.

" Add/Remove Server Cormponents Wizard

Choose Server Components

The list shows the server components installed and available for
installation. To add a component, enable its check box. To remove a
component, uncheck its box.

‘Cumpunant Name Description =

BRU Backup Server The backup server provides backup service!
Certificate Manager Creates and manages security certificates,
DHCP Server DHCP server for automatic IP address assi¢
DNS Server Domain name server solution based on bin—'
Firewall A firewall solution that is based on iptables.
FTP Server Secure and fast FTP server based on vsftpd
Helix Server Streaming-media server,

7] Print Server Enables multiple users to print to one or m
Proxy Senver High-performance proxy caching server sol

Adding or removing server components

Xandros Networks is a secure service that provides easy access to the
components and updates for your Xandros installation. It is also your source
for purchasing upgrade components and additional user licenses for Scalix e-
mail and calendaring, BRU backup, Helix media server, and other
components.

There are even Software and Management License components within xMC
that provide an interface to manage applications and licenses on the computer.

Custom server components

The architecture allows you to integrate management of third-party services
within xMC, just like any other xMC component. Examples of third-party
plug-ins already included with Xandros Server are the BRU Backup Server,
Helix Server, and Scalix Xandros Edition.

Obtain the Xandros Server Developer Guide from the Xandros Server Web
site or Xandros Technical Support, and then create your own components for
custom services you want to provide.
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Integrated backup facilities

Xandros Server includes an integrated BRU Backup Server from TOLIS
Group to deliver reliable backup and recovery while simplifying the complex
task of protecting critical system files and user data. You can easily schedule
backups for your servers, file shares, FTP sites, Web sites, and various
configuration files for firewall and other services. The computers backed up
can be Xandros Servers, Xandros Desktop computers, and even Windows
computers.

The BRU Backup Server is aware of other services within your Managed
Community, including other computers that have registered for backup
services. For example, you are prompted to include a new Web or FTP site
when using the backup service, assuring that all services requiring backup are
covered and saving you from bothering other administrators to add or change
their settings.

Web Community
Management
Server

Using a backup server
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Integrated mail and calendaring services

The Scalix Xandros Edition incorporated in Xandros Server is a Microsoft
Exchange alternative for Linux that provides enterprise customers with mail
and calendaring services, with full-function support for Microsoft Outlook, as
well as a broad range of POP and IMAP clients.

Scalix provides connectors for both Microsoft Outlook on Windows and
Evolution on Linux as clients for enterprise calendaring and scheduling with
real-time free/busy lookup, contact and task management, public folders, rich
text formatting, offline folder synchronization, secure delegate access to
calendar and e-mail, and e-mail rules.

(] = EVoIition S N ox(7 tota |_f 2 ‘
File Edit View Folder Message Search Help
=
(& new it} & & B g < @ .
Send / Receive Reply Reply to Al Forward Print Delete Junk Not Junk
= Inbox Jtotal | Subject or Sender contains |VH l Clear
e o) (28] e From | Subject | Date 12
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Using Evolution to access mail and calendaring functions of your Scalix server

Overview 21



n Xandros Server Getting Started Guide: Chapter 2



Installing Xandros Server 3

The installation process is:
¢ Check that the computer meets system requirements

Install Xandros Server
e Start up and log in
¢ Install updates

When you install Xandros Server, you are installing an operating system, the
server software, and desktop applications.

System requirements

System requirements are determined by:

¢ Xandros Server baseline requirements

* Your server functions, such as if you will use the computer as a file server
or Web server

Ensure the computer meets the minimum requirements for Xandros Server:

¢ Intel Pentium 4, AMD Athlon or Opteron, or compatible processor for 32-
bit version

¢ Intel EM64T, AMD Opteron or AMD64, or compatible processor for 64-bit
version

e 512 MB of RAM or greater (2 GB recommended)

¢ Adequate unallocated space available on the hard disk, with 40 GB
minimum and 120 GB recommended. Xandros Server itself takes at most 2
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GB, but 40 GB is the minimum if you want to use the computer as a file or
file transfer protocol (FTP) server, for example.

Xandros recommends the use of a redundant array of independent disks
(RAID) storage system. Using a RAID system, data is stored on multiple
hard disks, which appear on the system as a single disk. RAID helps to
protect data and improves performance. Xandros recommends hardware-
based RAID instead of software-based RAID.

¢ CD drive (must be bootable)

* Video card and compatible monitor capable of 800 x 600 resolution
(1024 x 768 recommended)

* Mouse or similar pointing device
* Keyboard

¢ Network card (Ethernet connection with speed of 100 Mbps minimum and
1 Gbps recommended)

¢ Internet service (to get updates)

Additional system requirements depend on intended use of the computer. For
example, hard drives with ample capacity are required if you intend to use the
computer as a file, Web, FTP, and/or electronic mail server. For a mail server,
the faster the disk access speed (seek time), the better. For a proxy server, a
regular computer likely meets requirements, but you want lots of RAM for a
large cache, low random seek time for fast access to the hard disk and RAM,
and ability to handle peak loads. Multiple Ethernet cards can be required, for
example when the computer acts as a firewall to internal and external
networks. A media server that creates video content requires a powerful
computer. When creating virtual machines, you want large disk capacity and
RAM, for example, to accommodate each operating system that you install.
See the individual chapters in the Xandros Management Console
Administrator Guide for more guidance.

To check system components on a Windows computer
| Click Start » Control Panel.
1 Click System.

To check system components on a Xandros OS computer
| Click Launch » Control Center » Control Center, then Hardware
Information.

1 Click the device for which you want information. For example, click
Hardware Detection to list the audio/sound card, CD drive, network card,
and video card of the computer.
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Hardware compatibility

Ensure that your computer hardware is compatible with Xandros OS.

To check hardware compatibility
¢ See http://support.xandros.com/hcl.php

If you try to install Xandros Server on a computer that includes
A incompatible hardware, it may not install or some features may
not work.

Understanding disk partitioning

Xandros Server can be installed on a new hard disk or one in use. It can be
installed on a hard disk that already contains an operating system, to either
overwrite or coexist with that operating system. Because Xandros Server is
intended to run all the time, coexistence with another operating system is not
recommended.

Hard disks typically have one main partition. If you want the Xandros
installation to coexist with another operating system, a separate partition is
created on the hard disk.

Partitions can be created using the Xandros installation wizard or by you. The
Xandros installation program is automated and requires little input. Otherwise
you can create partitions yourself if you know how or using Xandros Storage

Manager. A partition table keeps track of the partitions on your hard disk and
lets you add, edit, and delete partitions.

The table outlines the options available in the Xandros Installation Wizard.
Xandros recommends using the wizard to partition the disk.
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Install option Explanation

Use free Searches for unallocated space on the hard disk.

space Unallocated space is space not defined. When there is
enough space, Xandros Server is installed into it.

Take over Erases all existing information and formats the hard disk

disk or or a specified partition. Xandros Server is installed into

partition the disk or partition.

Resize a Lets you resize FAT, FAT32, and NTFS file systems to

Windows reallocate space for use as a Linux system. It shrinks a

partition Windows partition and installs Xandros Server within the
resulting free space. If you have Windows Vista installed
on the computer, use the native Vista tool to resize the
partition instead of the Xandros installation wizard.

Replace Replaces a previous version of a Xandros product on its

existing partition, optionally keeping some of your defaults,

Xandros OS including the home directories, user accounts, and user

folders, but not Xandros Server component settings or
files. Home directories are saved with an _old extension.
Xandros recommends exporting any address books to
other formats within the address book application before
upgrading (the LDIF format works well). For an
encrypted local user account, to keep the files, unencrypt
the home folder first. To keep any desktop wallpapers
added by you, ensure that they are in your home folder.
Xandros recommends upgrading from previous versions
of Xandros Server, not Xandros Desktop installations.

table continued
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Install option

Explanation

Manage disks
and partitions

Lets you assign and delete existing partitions. On a
computer without an operating system or a disk with free
space, it also lets you add a partition. The wizard lets you
use an existing partition but does not let you change its
size. Partitioning is not recommended by Xandros in the
sense that if you have a 60 GB disk, Xandros
recommends using the entire disk for Xandros Server.
Otherwise, a partition of 40 GB minimum is required and
120 GB is recommended.

With a RAID system, data is stored on multiple hard
disks, which appear on the system as a single disk.
During installation of Xandros Server, you can delete non-
functioning RAID configurations, for example you can
remove the RAID headers from an array of disks and
convert them to individual integrated drive electronics
(IDE) or serial advanced technology attachment (SATA)
disks. You delete a RAID configuration because it is a
non-functioning array (you removed a disk and want to
install on the remaining disks) or because it is an array
that does not exist on the system because it was moved.
After removal, data that was stored in the RAID array
may not be accessible. Another option is to use the BIOS
RAID configuration tool during startup, but this will not
work in all cases, for example if you have a drive that was
previously in a different computer that had a different
BIOS RAID manufacturer, then the BIOS tool will be
unable to remove any headers.

You can use logical volume management (LVM) during
installation to partition your disks, as explained later.
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Installing Xandros Server

Based on the function of the computer, there are three installation options:

¢ Community Management Server as PDC — A Community Management
Server can function as a server providing all or some services, manage
other servers and network user accounts as a Primary Domain Controller
(PDC), and functions as a Lightweight Directory Access Protocol (LDAP)
server. Using LDABP, it stores information that facilitates finding and
accessing computers and other resources by relating names to network
addresses, for example doing auto-completion when a user types an e-mail
address. LDAP is integrated into the components when appropriate and
runs in the background. For the first installation, you designate the
computer as the Community Management Server with PDC functions;
there is one Community Management Server per Managed Community.

* Member Server — A Member Server is associated with a Community
Management Server and as such is part of its Managed Community. For
the second and subsequent server installations, you normally perform this
type of installation. To create a Member Server, during installation you
reference the computer to a Community Management Server.

* Community Management Server as non-PDC (stand-alone) — Use this
option when you are installing into a network with Windows Small
Business Server 2003, with which trusted domain relationships cannot be
established. To use this option, during installation you designate the
computer to be a Community Management Server, without PDC functions.

The license allows you to install Xandros Server on one computer. When
using the Advanced edition, you can manage up to 25 user computers. Read
the license before or during installation.

Installation takes about 20 minutes for an experienced user performing a
regular installation on a 2.4 GHz computer; additional configuration can take a
half hour or so.

Use the 32 bit version of Xandros Server if you intend to use Scalix Xandros
Edition. You can install the 32 bit version on 32 or 64 bit hardware/processors.

Xandros Server cannot be installed on an Apple Macintosh computer.

Some server components are required and others can be deselected during
installation. Even a home office can use most of the services, for example
backup, DHCEP , file, firewall, FTP, print, proxy, time, and virtual private
networking (VPN) servers, while DNS, mail, and Web servers are likely to be
located at an Internet service provider. Components required and installed by
default include those for logging events, file servers, user accounts, and
Windows networking. The selection also depends on the edition you
purchased.
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The table outlines components that can be deselected during installation of

the Standard edition.

Optional component

Function

RealNetworks Installs the RealProducer application that allows
you to produce content in the RealAudio and
RealVideo formats for the Helix Server

BRU Backup Server Backs up and restores user and other files locally

or over a network. Xandros Server, Xandros
Desktop, and Windows computers can be backed
up, for example.

Certificate Manager

Lets you use security certificates. Required
component when the Web Server component is
installed, but only one Certificate Manager is
needed when you have many Web servers.

DHCP Server

Allows user computers to be configured for
networking automatically over a network, for
example provides Internet protocol (IP)
addresses

DNS Server

Tracks names and addresses of computers so
that they can be accessed, for example to access
Web pages by domain name instead of IP address

Firewall

Establishes network zones, lets you control open
and closed ports, as well as allows or blocks
specified IP addresses

FTP Server

Runs file transfer protocol (FTP) sites for
viewing, uploading, and downloading files over
the Internet

Helix Server

Runs streaming media, such as videos

Print Server

Enables multiple users to print to one or more
printers

Proxy Server

Retrieves and caches Web content for users

Remote xMC Service

Allows you to run Xandros Management Console
from a Windows XP or Vista computer, thereby
allowing remote access to Xandros Server
computers

table continued
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Optional component Function

Routing Configures connections to other subnetworks

SSH Server Allows remote access to Xandros Server
computers, including Xandros Server
components over the Internet from a Windows

computer
Time Server Keeps the time on user computers synchronized
UPS Monitor Monitors power supply to a Xandros Server
computer
Virtual Machine Allows you to run other operating systems and
Manager applications in a window on the desktop
VPN Server Allows users to access your network over the

Internet by virtual private networking

Web Server Runs Web, wiki, and blog sites

Use one of the following installation procedures:

¢ Xandros Server installs on a computer without an operating system,
upgrades a previous version of a Xandros product, or replaces another
Linux operating system

» Xandros Server replaces a Microsoft Windows operating system

* Xandros Server coexists with one or more other operating systems on the
same computer. The idea is to have the Xandros Server computer running
all the time, so this option is not recommended. When using RAID, ensure
that both operating systems support RAID the same way.

If you need help identifying partitions, see “To determine the partition
number” on page 85.
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To install Xandros Server on a computer without an operating system, upgrade a Xandros prod-

uct, or replace another Linux operating system

| If you are replacing another Linux operating system, back up any data or
folders that you want to keep. If you are upgrading Xandros Server, use the

BRU Backup Server component to backup xMC data, such as Web sites,
backing up to a tape or another computer.

1 Remove all media from drives, such as floppy disks and CDs, and
disconnect USB hard disks and memory sticks.

3 Insert the Xandros Server Installation CD into the drive. Use the 32 bit
version if you intend to install Xandros Scalix Edition.

4 Restart the computer, and wait for the Xandros Installation Wizard.

If your computer restarts without displaying the wizard, see
“Troubleshooting installation” on page 48 and try again.

xandros

Standard Edition

welcome Xandros Installation Wizard

—

SERvVER

cancel

Welcome window
5 In the Welcome window, click the Next button.
6 Inthe language settings window, set keyboard, language, and other
defaults as follows:

Locale — Sets currency, time format, date format, and similar default
values
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Language — The language version of the Xandros product, meaning a
translated version. The language package needs to be provided with the
product.

Keyboard Layout — For example, when you apply the French keyboard
mapping to your keyboard, pressing the A key types the letter Q. Please
note that not all keyboard layouts work in Linux (for example Japanese)
and that additional installations from Xandros Networks can be required for
the mapping and fonts to work properly.

Click Next.

Read the license agreement. To continue, enable the I accept this
agreement option, then click Next.

xandros

Standard Edition

End User License Agreement

Welcome ) ) )
Please read the following license agresment. To continue with the installation, you must accept the

License agreement.

XANDROS SERVER SOFTWARE
LICENSE AGREEMENT
IMPORTANT: CAREFULLY READ THIS LICENSE AGREEMENT BEFORE USING THIS PRODUCT.

CLICKING ON THE "ACCEPT" OR "YES" BUTTON IN RESPONSE TO THE ELECTRONIC LICENSE
AGREEMENT ENQUIRY AS TO ACCEPTANCE OF THE TERMS OF THIS LICENSE AGREEMENT, INSTALLING
OR DOWNLOADING THE SOFTWARE, INDICATES ACCEPTANCE OF AND AGREEMENT TO, AND LEGALLY
BINDS YOU ("CUSTOMER") AND XANDROS, INC, (ON ITS OWN BEHALF AND ON BEHALF OF ITS
SUBSIDIARY, XANDROS CORPORATION) (COLLECTIVELY "XANDROS") TO THE TERMS AND CONDITIONS
OF THIS LICENSE AGREEMENT (INCLUDING ANY TERMS, CONDITIONS AND RESTRICTIONS CONTAINED
IN ANY QUOTE ISSUED BY XANDROS RELATING TO THE SOFTWARE). IF THE CUSTOMER DOES NOT
ACCEPT AND AGREE TO THE TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT THEN EITHER DO
NOT DOWNLOAD, INSTALL OR OTHERWISE USE THE SOFTWARE.

1. Definitions
The following terms shall have the following meanings when used herein:

(a)  "Authorized Desktop OS Software" means an operating system software program supperted
are, as set out from time to time in the Xandros price list.

el

€ 1 do not accept this agreement

Accepting the software license
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8 Type the serial number for Xandros Server, and click Next. The serial
number is 25 digits long. If you have a trial version, this window does not
appear.

xandr:

Standard Ed

Welcome
License

Serial Number

Serial Number Validation
To validate this copy of Xandros Server and for registration purposes, type the serial number. The serial
number is located in the product box or provided by e-mail if purchased by other means,

Serial number;
|FVBCBE—23456—QBCDE—23456—RBCDE

Inputting the serial number

9 To install all available desktop applications and server components, click
Next. Otherwise, disable the check boxes of those that you do not want to
install, and click Next. See the table at the beginning of this section for
information about the components. If you deselect any server options, you
can install them later.

xandros

Standard Edition

Welcome
License

Serial Number
Software

Software Selection

Enable the check boxes of the applications to install

Software list:

Group Size single Size

[ Graphics
k- [ Internet
Realletworks
Server Components
BRU Backup Server
Certificate Manager

B Network Accounts

Description:

xXandros Server installs an operating system, server software, and other applications. Select or
deselect the applications to install here

cancel

Selecting software for installation
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[0 If the Virtual Machine Manager option was enabled on the previous screen,
you are asked to verify installation. If you do, a Xen-enabled kernel is
installed that can use more memory and is less compatible with some
hardware, so install the component only if you want to run virtual
machines. Click Next.

xandros

Standard Edition

Virtual Machine Manager
Welcome
You have selected to install the Virtual Machine Manager that allows you to run multiple virtual
License machines. By selecting this option, regular and Xen-enabled Linux kernels will be installed, and you will
: be able to choose at startup. The Xen-enabled kernel uses more RAM and may have hardware
Serfal Number compatibility issues not found in the regular Linux kernel
Software
If you are not planning to run virtual machines, you can skip installation of the Wirtual Machine Manager
by clicking No.

Do you want to install the Virtual Machine Manager as selected?
 es!
C Ng

Cancel

Verifying installation of the Virtual Machine Manager component

[l Enable one of the following options. Only the options applicable to your
computer are available for selection.

* Use free space — Uses the largest unallocated space on the hard disk

* Take over disk or partition — Takes over an entire hard disk or
specified partition; all data is erased. You can use this option to
completely erase an old version of a Xandros product and all your
folders and data.

* Resize a Windows partition — Shrinks a Windows partition and installs
within the resulting free space. (If you have Windows Vista, use the
native Vista tool to resize the partition instead of the Xandros wizard.)

* Replace existing Xandros OS — Replaces a previous version of a
Xandros product, optionally keeping existing user accounts and folders,
which are renamed in the format _old, and some defaults. It does not
keep your Xandros Server files, for example Web site files, so back
them up first.
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* Manage disks and partitions — You reassign a partition and install onto
it. When installing on a computer without an operating system or with
a free space entry on a disk, you can add a partition and install onto it.

Click Next.

I2 The next screen varies based on selection. A Disk Configuration window
can appear from which you select the disk or partition to use. Select it.

Disk Configuration - Manage Disks and Partitions
Welcome

Select a disk or partition to manage, then assign mount points
Higeag Disk and partition Jist:
Serial Number Valume

File System Size Mount Point [Format |
Software IDE1 18.64 GB
-~ primary (hdal) Linus - swap 500 MB [swap] yes
primary (hda2) 4,88 GB
Metwori free space (primary) 13.27GB
IDE2 18.64 GB
-~free space (primary) 18.64 GB

Disk

Assign... | Unazsion.. | Browse.. | Delete. |

Selecting a partition to use for installation

If the Add button is displayed and you want to add a partition, click it, set
the File system and Size, and click OK.

If the Assign button is displayed, click it and in the Assign Mount Point
window, leave the Mount point set at / so that you install into the root
directory, then select a File system:

* Ext2 or Ext3 — Ext3 is the default file system. Choose one of these
options if you use PartitionMagic to partition your disks
(PartitionMagic does not support ReiserFS). Ext3 is the successor to
Ext2 and functions better when the system encounters a problem,
such as a power failure.

* ReiserFS — Generally better performance than Ext2 or Ext3 in terms
of disk space use, access, and crash recovery

* Reiser4 — The latest version of the Reiser file system. Fastest file
system, more space efficient. Faster copying speed than ReiserFS and
Ext3.
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When active, enable one of the following options:

* Replace existing file system — Formats the disk or partition and
erases all data on that disk or partition

* Rename...folders... — Keeps your /root and /home folders and their
contents, and renames them with _old

* Leave existing file system unchanged — This option is not
recommended because it is good for system files to be formatted for
the installation

Click OK to exit from the Assign Mount Point window.

To avoid issues booting, keep various mount points on a single controller,
be it SCSI, IDE, RAID, or LVM for example.

You can delete non-functioning RAID configurations, for example you can
remove the RAID headers from an array of disks and convert them to
individual IDE or SATA disks and install Xandros Server on one of them.
You delete a RAID configuration because it is a non-functioning array (you
removed a disk and want to install on one of the remaining disks) or
because an array does not exist on the system because it was moved. After
removal, data that was stored in the RAID array may not be accessible.
Select the BIOSRAID entry, click the Remove BIOS RAID button, and
confirm the deletion. The button is active only if a RAID array is selected.

Click Next to continue in the wizard. Depending on your configuration, you
can be prompted to configure the disks for logical volume management
(LVM). LVM is advanced disk management that allows you to easily add or
replace hard disks and detect them automatically, and particularly to pool
space of multiple disks, for example 10 GB from one disk and 20 GB from
another disk to render a block of 30 GB. Three partitions are required:

/, /boot, and swap, which you can create by assigning partitions in the same
panel. If you use LVM, your partitions will then be mapped by the
installation program into LVM logical volumes. If you do not configure your
partitions to use LVM, you can still pool space of multiple partitions on a
single disk, but not pool space of multiple disks.
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13 In the second Disk Configuration window, to use the default Xandros boot
manager (recommended), click Next.

A boot manager determines the screen shown on startup, for example to
select one operating system to launch instead of another. If you want to use
something other than the default boot manager at startup, select it from
the Install boot manager on master boot record list box (must already be
mapped to the Xandros partition for a second option to appear). Or, when
you have a boot manager that can be configured after installation, you can
deselect the check box.

xandros

Standard Edition

Disk Configuration - Take Over Disk Summary

Welcome
Please review the settings. If you want to make any changes, click Back. If you are satisfied, click Next.
License Warning: All cantents of the selected disk will be lost when the install process completes.

Serial Number Partition summary:

Volume File System Mount Paint Size

IDEL 18.64 GB
i~ primary (hdal) Ext2 Jboot 100 MB
i~ primary (hda2) Linux - swap. [swap] 755 MB
*-primary (hda3) Ext3 s 17.81 GB

Software

Boot manager options:
I install boot manager on master boot racord of:| [IDEL (hda) |

Note: A copy of the boot manager will also be placed on the root partition (hda3),

Cancel

Using the default black Xandros startup screen
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14 Inthe Network Connection Configuration window, type a name for the
Xandros Server computer in the Computer name box. The default is
xanserver. Make it unique on your network and if you intend to have more
than one installation of Xandros Server, for example xanserverl or
proxyserverl. Make it 15 characters or less if the computer will be on a
Windows network.

In the DNS domain box, type the name of the local network domain, for
example, yournetwork.com or newyork.xandros.com

xandros

Standard Edition

Network Connection Configuration
Welcome

Please enter a computer and domain name to identify the computer.
License

Computer name; [xanserver
Serial Number

DNS domain:  [mydomain.com
B Configure Connection

Select @ Enable network connection using: fpr disable t.

Software
Disk

Network
Local & ¢ Dynamic address (DHCP)

COl @ static address Interface [ Link

Static (172.16.5.3) etho i
IP address: 172, 16 . 5 . 3 Rl S e &
Subnet mask: 255. 255 0 o

" Disable network connection

¥ Use the following DNS server addresses

Preferred DNS server: [172, 16 , 0 , 1
Alternate DNS server: |172. 16 3 i

Configure..

Defaulf

Cancel

Naming the computer and setting network configuration

Select each network interface, click Configure, and enable one of the
following options:

* Dynamic address (DHCP) — When the IP address of the computer
changes each time you connect to the network, for example to your
Internet service provider, choose this option. Xandros recommends
using a dynamically assigned static IP address for the Xandros Server
computer. Some components require use of a static IP address,
including BRU Backup, DHCP, mail, FTP, proxy, time, and Web server.
Use of a static IP address is also recommended for firewalls, DNS, and
VPN servers.

» Static address — When the computer has a static IP address assigned
to it, enter it in the IP address box and enter the Subnet mask. Assign
a static IP address when it is the first Community Management Server
installation and you do not have an external DHCP server (like on
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Windows) giving it its address. In general for installations, if you
cannot use a dynamically assigned static address, Xandros
recommends use of a static IP address, and you must use a static IP
address if you intend to use the computer as a backup, DHCP, mail,
FTP, proxy, time, or Web server, for example. Use of a static IP address
18 also recommended for firewalls, DNS, and VPN servers.

* Disable network connection — To prevent network connections
through the selected device and never use the Internet, for example.
In order to install updates to Xandros Server over the Internet you
require a network connection. If you have an extra network card in the
computer that will not be used, disable it so that it does not interfere
with the other network connection.

Click OK to return to the wizard.
If any of the following fields are active, complete them:

Default gateway — An IP address. A gateway is a computer that connects
networks to each other, for example within a corporation or at the Internet
service provider for a home user. Firewall servers and proxy servers are
examples of gateways. A router is a gateway; if yours has an IP address,
enter it here.

Preferred DNS server — If you have a Domain Name System (DNS)
server for domain name lookups, you can specify its IP address. A DNS
server translates Internet domain names into IP addresses so that
computers recognize them.

Alternate DNS server — The DNS server to use when the preferred DNS
server is not available. Enter its IP address (optional).

Click Next. If you see a message about the gateway needing to match,
change the subnet mask of the network connection, to 255.255.0.0 for
example.
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I5 If the Administration Configuration window appears, complete it:

e Administrator password — Type a password for the Administrator
account. The password must be a minimum of six characters. This
account is used to log in to the desktop as Administrator (root).

* Confirm password — Retype the password

* Enforce strong passwords — To make it more difficult for a password
to be compromised, the check box is enabled by default. The wizard
checks if the password is acceptable to this higher standard. For
example, it disallows the use of common words.

* Make user home folders private — To disable sharing of home folders,
enable this check box. If you have multiple user accounts and thereby
multiple home folders, users will be able to access and browse each
other’s folders unless you enable this option. Other users still have
access to private home folders when a user is logged in regardless of
encryption.

Click Next to continue in the wizard.

Administration Configuration

Welcome
Flease enter a password for the administrator (root) account, Use this account enly to perform
License administrative tasks on this computer.

Seril Number Adrinistrator password oo
software Comtmpssmord: [

Disk
Network
Administration

Please select additional security options.

¥ Enforce strong passwords

USELACCOLNS
I~ Make user home folders private

rCarhgurason

Entering the desktop Administrator password
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I6 If the User Account Configuration window appears, click Add to add a user
account (optional and recommended). This user account is for access to the
desktop. Complete the Add/Edit User Account window:

User name — Type the user ID of the user. This is the name for
logging in to the desktop, such as jimmyk. Spaces cannot be used.

Full Name — Type the full name of the user, for example Jimmy King.
Spaces are allowed.

Password — Type a password for the user
Confirm password — Retype the password
Click OK to exit from the window.

Click Next to continue in the wizard.

xandros

Standard Edition

Welcome

License

Serial Number
Software

Disk

Network
Administration
User Accounts
Server Configuration
SUMEr

User Account Configuration

To maintain the security of your computer and your personal preferences, Xandros recommends
creating an account for yourself and each person who will Use this computer. Click Add to create an
account,

Please enter the user name and password. The
user name can contain lowercase letters, numbers,
and hyphens.

User name: xandrosuser
Eull name: Xandros Server User

Password: O —
Confirm password: [tremewss

Cancel

Setting up a desktop user account
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[7 In the Community Management Server window, enable the Yes or No
option to specify if you want the computer to be a Community
Management Server. A Community Management Server can function as a
server, manage other servers and network user accounts, and function as
an LDAP server. For a stand-alone installation, you want it to be in its own
domain, so make it a Community Management Server. For a Member
Server, enable No. For the first installation, leave the Yes option enabled.
These options were discussed earlier.

Click Next.

Community Management Server

Welcome

Xandros Servers co-exist in a Managed Community so administrative tasks that span multiple services on
License multiple servers can be achieved seamlessly in a centralized manner.
Serial Number Each Managed Community requires one dedicated Xandros Server to act as the Community Management
Software server.

Disk Would you like this server to act as a Community Management Server?

Network  Yes, make this server my Community Management Server |

Administration € No, another server is already setup as a Community Management Server
User Accounts

Server Configuration

UMM

Establishing a Community Management Server
18 If the Community Management Server window appears, complete it:

* Managed Community name — Type a name for the Managed
Community. The field is autofilled using part of the DNS domain
entered earlier by you. This name will also be used as the domain, so
use a domain that does not already exist.

* Administrator name — Type a name for the master Administrator
account for the server components, meaning to access Xandros
Management Console (xMC). This administrator can use Xandros
Server components and create other administrator accounts with equal
or fewer privileges. The default user name is administrator.

* Full name — Type the name of the administrator. The default is
Administrator.

*  Password — Type a password for account. Acceptable values depend
on whether strong passwords are being enforced.

*  Confirm password — Retype the password

e Act as Windows PDC — Leave this option enabled for the first
installation; one computer must function as the PDC for user accounts
in a Managed Community. Disable this option when you want the
computer to be part of an existing domain.
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¢ LAN management connection — When more than one network card is
detected, from the drop-down list select the network connection that
the Xandros Server computer is to use to communicate with members
in the Managed Community.

Click Next.

xandro

Standard Edition

Welcome

License

Serial Number

Software

Disk

Network

Administration

User Accounts

Server Configuration

Community Management Server

You have selected this Xandros Server te also function as a Community Management Server in a
Managed Community of its own. Please provide a name for this Managed Community, ensuring that it
does not match any Windows demain name or any Windows computer name that is on the network
already,

Managed Cormmunity name: [T EMRN

The Managed Community requires an administrator to manage accounts and servers through the use of
Xandros Management Console (xMC). Please enter a password,

Administrator name: Iadmlmstratnr

Full name: [administrator

Password: |mmw

Confirm password: ~ [rrevvwer

The Community Management Server can act as a Windews® Primary Domain Controller (PDC) for your
network. Please make a selection.

7 Act as Windows® EDC

Cancel

Naming the domain and configuring xMC administrator account
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19 For a Member Server installation, in the Community Management Server
window, specify the Community Management Server to use: type the IP
address or computer name of the Community Management Server to be
used to manage the installation. Examples are 172.16.5.1, xanserver,
proxyserverl, and xanserver.company.com If you have Xandros Server
installed, you can view the IP address in the Managed Community
component. If you enter a name, it must be immediately resolvable
through DNS, meaning in your DNS server the domain is set to
company.com and a xanserver entry is configured to point to the
Community Management Server IP address. The location of the
Community Management Server is checked before proceeding, so it must
be running. For best results, use the IP address.

Click Next.

xandros

Standard Edition

Community Management Server - IP Address or Computer Name
Welcome

This Xandros Server needs te be managed by a Community Management Server, Please provide the IP
License address or the name of the Community Management Server. If you provide a name, it must be resolvable

Serial Number $ERUAIDNS,

IP address or computer name: 3
Stware p [17216:51

Disk

Network

Administration

User Accounts

Server Configuration
SUmmary

Specifying a Community Management Server for a Member Server

20 In the Windows Server Interoperability window, you can specify if the
computer acts as or uses a Windows Internet Naming Service (WINS)
server. A WINS server provides address resolution for Windows
computers, mapping computer names to IP addresses so that computers
can recognize them, similar to a DNS server. Use is recommended. Select
an option:

* Xandros Server to act as WINS server — To have the computer
function as a WINS server

* Use this WINS server — To specify an existing WINS server, enable
the option and type its IP address. You can view it on Xandros and
Windows computers in the Network Connections panel.

* No WINS server support — To ignore WINS, for example because you
only have Linux computers

Click Next.
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Welcome
License

Serial Number
Software

Disk

Network
Administration
User Accounts

Server Configuration

windows® Server Iinteroperability

Xandros Server can act as a Windows Internet Naming Server (WINS) server or use an existing one.
Please make a selection.

€ Xandros Serverto act as WINS server

= Use this WINS server
172, 16, 0, 1

Mo WINS server support

Specifying WINS server use

2l In the Graphical User Interface window, to start Xandros Server from the
command line instead of the graphical user interface, enable the Do not
load GUI at startup for this computer check box, then click Next. To
explain, a graphical user interface is not required when the computer will
only be managed remotely or does not have a monitor attached. The non-
graphical startup is also more secure and less resource-intensive. If in
doubt, leave the option unchecked.

Standard Edition

Welcome
License

Serial Number
Software

Disk

Network
Administration
User Accounts

Server Configuration

Graphical User interface
¥andros Server can run without loading the graphical user Interface at startup.

A GUI is not required for this computer if it will only be managed remotely or does not have & moniter
attached.

Another computer |s required with Xandros Management Console (xMC) installed to remotely manage
this computer,

I™{Do not load GUI at startup for this computer;|

Option to use command line for login

12 In the Installation Summary window, check the information. If you need to
change any settings, click Back. Otherwise, click Finish to perform the
installation. Xandros Server is installed.

If you chose to take over a disk or partition, the contents of the
disk or partition will be erased.

If you have problems installing Xandros Server, see

“Troubleshooting installation” on page 48.
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To replace a Microsoft Windows operating system with Xandros Server
| Back up any data or folders that you want to keep.

1 The installation is similar to the previous one. In the Disk Configuration
window, you enable the Take over disk or partition option.

All data and files on the disk or partition used will be erased
A before installation.

To install Xandros Server to coexist with another operating system (Windows XP example)

| If Windows is not already installed, install it first and preferably on a
separate hard disk.

1 Remove all media from drives, such as floppy disks and CDs, and
disconnect USB hard disks and memory sticks.

3 Inthe My Computer window in Windows, check if you have an NTFS-
formatted hard disk by right-clicking the disk and selecting Properties.
Check if the File system setting reads NTFS.

If you have an NTFS disk, to ensure that the partitions are resized
properly, defragment the disk by clicking Start » Control Panel »
Administrative Tools » Computer Management » Disk Defragmenter,
then defragment the appropriate disk.

4 Insert the Xandros Server Installation CD into the drive. Use the 32 bit
version if you intend to install Scalix Xandros Edition.

5 Restart the computer, and wait for the Xandros Installation Wizard.

If your computer restarts without displaying the wizard, see
“Troubleshooting installation” on page 48 and try again.

6 Inthe Welcome window, click Next.

1 Inthe language settings window, set keyboard, language, and other
defaults as follows:

Locale — Sets currency, time format, date format, and similar default
values

Language — The language version of the Xandros product, meaning a
translated version. The language package needs to be provided with the
product.

Keyboard Layout — For example, when you apply the French keyboard
mapping to your keyboard, pressing the A key types the letter Q. Please
note that not all keyboard layouts work in Linux (for example Japanese)
and that additional installations from Xandros Networks can be required for
the mapping and fonts to work properly.

Click Next.
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Read the license agreement. To continue, enable the I accept this
agreement option, then click Next.

Type the serial number for Xandros Server, and click Next. The serial
number is in the box and is 25 digits long. If you have a trial version, this
window does not appear.

To install all available desktop and server applications, click Next.
Otherwise, disable the check boxes of applications that you do not want to
install, and click Next. See the table at the beginning of this section for
information about the components. If you deselect any server options, you
can install them later.

If the Virtual Machine Manager option was enabled on the previous screen,
you are asked to verify installation. If you do, a Xen-enabled kernel is
installed that can use more memory and is less compatible with some
hardware, so install the component only if you want to run virtual
machines. Click Next.

Enable one of the following options, and click Next:
* Use free space — Uses the largest unallocated space on the hard disk
* Resize a Windows partition — Shrinks a Windows partition and installs

within the resulting free space. (If you have Windows Vista, use the
native Vista tool to resize the partition instead of the Xandros wizard.)

Click Next.

If you chose to Resize a Windows partition, select the Windows partition
and specify the size to use for the Xandros partition. Then click Next.

Disk Configuration - Resize a Windows® Partition
Welcome

Select a Windows partition to resize. No data will be destroyed.
Heerse Windows partition list:

Serial Number
Software

Disk

Browse...

G [Mesoame
Xandros Server requires: [13s2mB
Size of Xandros partition: [sazsme 3]
New size of Windows partition: [10666 MB

Selecting the disk or partition to use for installation
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14 Complete the rest of the wizard, starting with step 13 on page 37.

If you install Xandros Server to coexist with one or more other

Ei] operating systems, install the other operating system first. If
you install Xandros Server first, then want to install Microsoft
Windows, insert the Windows CD into the computer and wait
for the installation wizard. If the installation wizard does not
automatically launch or work, back up your files, clear the hard
disk, install Windows, then install Xandros Server. If the black
Xandros startup screen does not appear, use the Restore
Xandros function to restore it.

When using RAID, ensure that the other operating system
uses RAID the same way.

Troubleshooting installation

For error 2000, if you downloaded the product, try another installation CD, for
example create it using a speed of 4x or less.

Error 4000 means the hard disk controller that your hard disk is connected to
is not supported. If you are using a serial advanced technology attachment
(SATA) RAID device/controller, install with another type of RAID or without
RAID. If you are using an integrated drive electronics (IDE) device and a
SATA controller, update your system BIOS and set it to non-enhanced mode.
Or try connecting any hard drives to another controller.

If you are unable to use the mouse, use a USB or PS2 mouse.

As outlined here, Xandros Server includes a troubleshooting menu that can be
used to install the product when it does not immediately recognize hardware.
You can also use the troubleshooting menu when your installation is
successful but have a hardware issue, such as no sound, to reinstall using
another option.

To use the troubleshooting menu for installation
| With the Xandros Server Installation CD in the drive, restart the computer.

1 When a message appears to press <SPACE> or type “menu” for
troubleshooting options, do so immediately, and press Enter. Access is
successful when the selection screen includes the following options. You
need to be quick to move the selection off Default Setup so that you can
make a selection.
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Option Description

Default Setup Default installation

Restore Xandros Restore the startup screen and installation
Rescue Console Diagnostic tools; vga=normal
International Setup Keyboard and language other than default
256-Colors Setup O1d monitor or video card

VESA Mode Setup Generic video support; acpi=on
Text Mode Boot Setup To start without showing the splash screen

ACPI 1 Setup Default installation
ACPI 2 Setup noacpi

ACPI 3 Setup pci=hiosirq

ACPI 4 Setup pci=noacpi

ACPI 5 Setup pci=nomsi

ACPI 6 Setup pci=nommconf
ACPI 7 Setup pci=assign-busses
ACPI 8 Setup pci=routeirq

APM 1 Setup acpi=off

where

ACPI means Advanced configuration and power interface that allows a
computer to hibernate and be re-activated by pressing any key; newer than
APM

APM means Advanced power management, such as turning off the monitor
and/or hard disk; older interface developed by Intel and Microsoft

pci=noacpi means that ACPI is not used to configure any PCI device

Using the down arrow, ¥, select APM 1 Setup, then press Enter.

If Xandros Server does not install, select ACPI 2 Setup. If it does not
install, try ACPI 3 Setup, then try the other ACPI, VESA, and 256-Colors
options until one of the options works.

If you use a keyboard and language other than the default (English), select
International Setup to install Xandros Server. For example, you can apply a
French keyboard mapping.

If Xandros Server still does not install, select Rescue Console, press Enter,
and type startx at the bash prompt.

If it still does not install, try booting the CD with the Scroll Lock on, type
install atthe prompt, and press Enter.

You can also check that the computer BIOS is set to boot from the CD
instead of a hard drive if you are having trouble installing.
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Getting updates

After installing Xandros Server, Xandros recommends that you download
updates, such as security updates. You can do so in the First Run Wizard that
appears the first time you log in. Updates can also be installed in the
Computer Management component of Xandros Management Console.
Otherwise, for instruction on getting updates, see “Installing updates and
applications” on page 71.
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Starting up 4

This chapter introduces the desktop environment, including how to:
e Start up

* Login

* Complete the First Run Wizard

* Log in to Xandros Management Console

* Lock the desktop and change the screen saver timing

* Change your password

* Logout

* Troubleshoot login and restore the installation

Starting up and logging in

After installing Xandros Server, you log in to the computer.

Starting up

When you start the computer, a menu displays startup options. When you
have more than one operating system installed, the menu lets you select the
operating system to start. The Safe Video Mode and Configure (Expert)
options are for troubleshooting.
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If you enabled the option during installation to start Xandros Server without
the graphical user interface, instructions are provided to use the command
line.

To start Xandros Server
| Start the computer.

1 When the black startup menu is displayed, with a Xandros Server option
selected, press Enter. Use the virtualization option when you have the
Virtual Machine Manager component installed and you want to use it.
Selecting the virtualization option loads a Xen-enabled kernel instead of
the regular kernel. By default, if 30 seconds elapses without a selection
being made, the option at the top of the menu is selected automatically and
startup continues to the login window.

default operating system in the Boot Manager panel of the
Control Center. This means you can start up faster.

Ei] You can reduce the default selection time and change the

To start Xandros Server without the graphical interface
| Follow the previous procedure.

1 At the prompt, log in as root. (You do not need to log in to manage the
computer remotely; you simply need to select Xandros Server from the
startup screen and reach the login prompt.)

3 At the prompt, to start the desktop to run as the root user, type
/etc/init.d/kdm start
and press Enter, which loads the login window. Do not use the startx
command because it circumvents the Xandros system.

4 Login as any user.

Logging in
You can log in to the desktop as a regular user or as Administrator (root).

In Linux, the account used for system administration is called Administrator
(root). By logging in to the computer as the Administrator, you have unlimited
privileges for the desktop: you can add and delete local user accounts, change
local user privileges, access all files, and configure Xandros OS. Only one
Administrator account for access to the desktop is allowed. Avoid working in
this account unless you need such access.
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The login window varies with installation.

User name: EEWEIOEEY
Pt otttk otk |

ser v

Log in Shut down...

e ks XANSERVERH (this machine)

Log in Shut down...

Logging in to a Community Management Server (left) and Member Server (right)

To log in

In the login window, select a desktop user account from the User name
drop-down list.

Type the password for the user account in the Password box.

If applicable, from the Domain drop-down list, select a domain to log in to.
You log in to the local desktop by selecting the “this machine” option, and
typically this is the option you select. You do not have to select the domain
at this time because you are not yet logging in to Xandros Management
Console (xMC). You do select a domain when you want to access a
computer remotely.

Click Log in. A desktop with a blue background loads by default for a user
account and red for the Administrator account. If you have problems
logging in, see the next section.

If you installed Xandros Server with 256-Colors Setup and the colors
displayed on your monitor require correction, change from 256-color mode
to another color mode by clicking Launch » Control Center » Control
Center, then Display, then Settings, changing the color mode in the Color
drop-down list, for example to True Color (24 bit) or High Color Plus (16
bit), and clicking Apply. Restart the computer.

If you installed with the VESA Mode Setup option and windows appear
large, increase the Screen Size in the Settings panel of the Control Center.

The screen locks by default after three minutes of inactivity. To

[i] change this time, click Launch » Control Center » Control
Center, click Display, then Screen Saver. Change the Start
automatically setting, and click Apply.
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Trash

""‘ —— Kandros File Manager

€ Virtual desktop

xandr

Xandros Management Console
(server components)

Xandros Networks
T (software updates)

) Applications
Find
™ Control Center
. Xandros File Manager
5] @ xandros Netuorks Lock the desktop
B b Help
Actions Software updates
Racent Documents

g1 © fun Command.. Launch button Virtual desktops

5] 56 Switch User

ﬂnu =3 HE O L) 1220pm s
Xandros Server desktop

To start Xandros O using specialized settings
| Start the computer.

1 When the black Xandros startup menu is displayed, press the down arrow,
{, to select one of the following options, and press Enter:

» Safe Video Mode — If you are unable to boot or log in to the desktop,
use this mode

* Configure (Expert) — If you are unable to boot or log in to the desktop
using Safe Video Mode, use this mode. This option is for advanced
users who are familiar with the UNIX command-line interface and who
are interfacing with technical support personnel. For example, you can
press Ctrl+D at the prompt to load the login window.

3 If you are still unable to log in, follow the instructions in “Troubleshooting
login” on page 61. Instructions are also provided there on manually loading
a driver in case a hardware component is not detected or does not function
immediately.
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Completing the First Run Wizard

The First Run Wizard automatically launches the first time each user logs in.

¥ PRI R Wizard

Welcome to First Run Wizard

< & The First Run Wizard helps you to easily customize your desktop

Which hand do you use to cperate your mouse?

@‘Blgh hand:

5\ environment. You can set the way numbers, dates, currencies and time are
displayed, desktop appearance and behaviors and more.

All of these settings can be changed later using the Control Center.

First Run Wizard to set basic default values

The wizard guides you through basic setup tasks, such as:
* Configuring the mouse

* Choosing regional settings, such as location and keyboard language.

Setting the locale automatically sets fields such as the character set, date

format, and currency.
¢ Setting the date and time
* Adding printers (off by default)

* Choosing default window styles and system behavior, such as Xandros

Desktop, UNIX, Microsoft Windows, or Mac OS behavior
* Registering over the Internet
¢ Installing updates over the Internet

Complete the wizard. If you do not want to add a printer, register now, or get

updates from Xandros Networks, for example, you can do so later. All of the

settings you select in the First Run Wizard can be changed later in the Control
Center. You can also access the First Run Wizard again by clicking Launch »

Applications P System » First Run Wizard.
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Starting Xandros Management Console

The server software is accessible on the desktop and from the Launch menu
as Xandros Management Console (xMC). xMC has three main functions:

¢ Allows authorized xMC Administrators to manage resources, such as file
servers and remote access

¢ Allows authorized xMC Administrators to add and delete user accounts,
including permitting others to access xMC

¢ When Xandros BridgeWays - Deployment and Management Edition
components are included, allows authorized xMC Administrators to deploy
Xandros products and compatible applications to computers over the
network and maintain them

xMC can be accessed from several computers, including Xandros Server,
Xandros Desktop, and Windows. To install xMC on a Windows computer, see
“Installing Xandros Management Console on a Windows computer” on

page 81.

For information on how to use xXMC to administer and manage services and
components, see the Xandros Management Console Administrator Guide.

Product registration is required before xMC launches. You are prompted to
register. Only the Community Management Server needs to be registered.

To start xMC

| Double-click the Xandros Management Console icon on the
desktop or click Launch » Applications » Server Management
» Xandros Management Console. A login window appears.

1 Type the name and password required to log in to xMC, for
example administrator, which is the default xMC administrator account
created during installation. Select the Managed Community domain from
the drop-down list or search for it by clicking Find. Click OK to log in. You
can be prompted to register.

.,rf" Please type an xMC administrator name and password
s or click Cancel.

Administrator: administrator

Password: |M-M-M-*- J

Community name: | g OTTAWAL -~ | Eind.

Cone

Login window for Xandros Management Console

If you are accessing Xandros Management Console for the first time and a
message appears that the account and password are invalid, it can mean
that there is no Internet access or that the Subnet mask used during
installation is incorrect. You can check which subnet mask is being used in
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the Network Connections panel of the Control Center or by entering
/sbin/ifconfig in a console window.

If you successfully accessed Xandros Management Console before and a
message appears that the account and password are invalid, it can mean
that use of the Dynamic Host Configuration Protocol (DHCP) is enabled
and the IP address of the Community Management Server has changed;
acquire a new IP address, use a static IP address, or reinstall.

When the software launches, a list of services and their status displays.
The components vary by product and edition. Components also vary based
on your privileges for the selected computer, which is displayed in the
Computer name field. A few services run by default, while others need to
be explicitly started.

A Xandros'Management Console s xanserveri.ottawa.xandros.ca

LA

File View Tasks Bookmarks Windows Help

Computer name: [ﬂ xanserverl.ottawa.xandros.ca

- O=E &

#%Managed Community -
e Xandros Management
@Computer Managemen
[@Local Accounts

& Network Accounts _
» BRU Backup Server Server Status | Statistics

[Slcertificate Manager

H};SDHCP Server Service | Uptime (day:hr:min)
fDNS Server @ BRU Backup Server Not running
@, Event Viewer @DHCP Server Not running
W File Server @DNSs server Not running
&) Firewall +/File Server: Windows ~ 00:04:55
[RAFTP Server | @ File Server: UNIX (NFS) Not running
# Helix Server @ Firewall Not running
{d Performance Monitor @FTP Server Not running

& Print Server N\

S Proxy Server \_
ZaRemote xMC Service . \
H2Routing

[+ G

Q0]

Xandros Management Console

3 Click the Statistics tab for a quick overview, such as the number of xMC
Administrators logged in, load, and memory usage.

" Server Status | Statistics l—'\J

‘Druperty |Va|ua ‘
User name administrator
Computer xanserverl.ottawa xandro..,
Users logged in 1
CPU usage 6%
Memory usage: Applications 174.68 MB
Memory usage: Buffers 51.11 MB
Memory usage: Cache 21150 MB
Statistics tab of xMC
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To exit from xMC

* Click File » Quit. Services continue to run, for example your Web server.
When the default start mode of a service is set to Manual, the service will
stop when you restart the computer.

terminate it by pressing Ctrl+Alt+Esc, then clicking the
application window.

Ei] When xMC or an application is non-responsive, you can

Protecting your desktop

You can lock the screen to ensure that no one accesses the computer when
you leave it, and you can change the login password.

Locking the screen

When you lock the screen, Xandros OS blocks access to the desktop.
You enter the password to unlock the screen and regain access to the @
desktop. The screen is locked by default by a screen saver after three
minutes, and you can change this.

To lock the screen
* On the Panel, click the Lock the Desktop icon.

To unlock the screen
* In the unlock computer window, type the login password, and click OK.

If the screen is blank, press a key or move the mouse to display
Ei] the login window.

To change the screen saver time
| Click Launch » Control Center » Control Center.
1 Click Display, then Screen Saver.

3 Change the Start automatically time after which Setting

the screen saver starts. 2 e e
. . o . After: |30 minutes =
4 The Require password to stop time specified is ) e e o
the delay before the password is required after afer: [pucfasconds ]2
the screen saver is activated. Change this if you Make aware of power management
want.

5 Click Apply.
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Changing your user password

You can change the password that you use to log in to the desktop. When you
are logged in as the Administrator, you can change the password for that
account and user accounts. When you are logged in as a user, you are changing
the password for that user account only. The changes outlined here do not
apply to Xandros Management Console.

W R

Change Password

¢l Display

& File Manager

it General Settings

M1 Hardware Information
& Network

<5 Peripheral Devices

1 Power Management
& Sound & Multimedia

Change Password [ Password Settings

Password Configuration

User name: serveruser

Current passwaord: [Wm ]

New password: [Wm ]

Confirm password: |W~=w J

o @y System Administration
™ Boot Manager
i Login Manager
& Managed Community
«# Remote Desktop Sharing
User Manager

Changing a user account password

To change your desktop password

Click Launch » Control Center » Control Center.

Click System Administration, then Change Password.
Type your existing password in the Current password box.

S W N —

Type a new password in the New password box. Use of a strong password
is recommended, that is, with a combination of characters and numbers
instead of common words.

5 Type the new password again in the Confirm password box.
6 Click Apply.

(1)

The Administrator can change the passwords for user accounts
in the User Manager panel.

Under the Password Settings tab, with the Timeout, you will
not be asked for a password for the length of time specified
after you have given your password once. This feature reduces
the number of times you need to enter the password.
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Logging out and shutting down

You can log in and out of the desktop as a different user. For example, you can
log in as Administrator to configure a setting, log out, and then log back in to a
user account. It is quicker than restarting the computer.

Xandros recommends leaving the servers on at all times, particularly the
Community Management Server.

Though the intent is to have the server running all of the time, you can also
shut down the computer. When you exit, with the Save session for future
logins option you can save your desktop view and restore it the next time you
log in. For example, you leave the Control Center open, then have it launch
automatically the next time you log in. Not all applications can be re-launched
automatically.

Log Out Xandros Session

Save session for future logins |

Log out Shut down Restart

Cancel

Logout window

To log out
| Click Launch » Logout. The logout window opens.

1 To save your desktop view, enable the Save session for future logins check
box.

3 Click the Log out icon. The system logs out and the login window appears.

To shut down
| Click Launch » Logout.

1 To save your desktop view, enable the Save session for future logins check
box.

3 Click the Shut down icon.
4 Enter the Administrator password for the desktop when prompted and
click OK. The system shuts down.

If you shut down a Community Management Server installation, a service
on another installation, such as for a file server, continues to run. The
computer can be slow, however.

If you shut down or turn off a server, its service cannot be
‘ j s used.
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To restart
| Click Launch » Logout.

1 To save your desktop view, enable the Save session for future logins check
box.

3 Click the Restart icon.

4 Enter the Administrator password for the desktop when prompted and
click OK. Depending on the settings, some server services will not be
running after you log in and need to be started.

Troubleshooting login

The startup menu provides options for troubleshooting login. If these options
do not work, use the troubleshooting menu instead. As outlined in the
previous chapter, also use the troubleshooting menu if your installation was
successful but have a hardware issue, such as no sound, to reinstall using
another option, or if an operating system is no longer selectable from the
startup screen.

To restore and start Xandros OS using the troubleshooting menu

| If the computer has more than one partition, you need to know which one
to restore. See “To determine the partition number” on page 85.

1 Insert the Xandros Server Installation CD into the drive.
3 Restart the computer.

4 During startup, when a message appears to press <SPACE> or type
“menu” for troubleshooting options, do so immediately, and press Enter.
Access is successful when a selection screen appears with the following
options:

Default Setup
Restore Xandros
Rescue Console
International Setup
256-Colors Setup
VESA Mode Setup
Text Mode Boot Setup
ACPI 1 Setup
ACPI 2 Setup
ACPI 3 Setup
ACPI 4 Setup
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5 Press the down arrow, {, to select Restore Xandros, and press Enter. You
are prompted for the partition to restore and to verify that you want to
restore it. When asked if you want to change the current command line,
enter no. When asked if you want to change the current boot device,
enter no. Xandros OS is restored and your files and some settings are
saved.

6 If that option does not work, repeat the procedure to select Rescue
Console. The Rescue Console provides diagnostic tools for configuring the
Xandros installation. It allows you to access a console window where you
can mount partitions and copy or modify files. It is useful if you forget your
password and need to copy files or reset your password. It is for advanced
users.

Manually loading a driver at startup

You can manually load a driver at startup. This procedure is for advanced
users.

Some hardware that is not supported or not automatically detected can
require manual loading of the kernel driver. For example, an ISA-bus network
card is not automatically detected, but usually works if the driver is loaded for
it. For example, a certain ISA-bus Western Digital network card uses the
“wd” kernel driver. You add a line containing the text “wd” to the
/etc/modules file. This action loads the driver at startup.

To load a driver

Log in as Administrator (root).

Click Launch » Applications » Accessories » Text Editor.
Open the /etc/modules file.

Add a line to this file in the following format:

S W N —

Module name  Options
sh 10=0x220 irq=5 dma=1 dmal6=-1
In this example, an ISA sound card driver is to be loaded.

5 Save the file and close the Text Editor.
6 Restart the computer. The driver will be loaded automatically at startup.
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Configuring Xandros Server 5

You can connect to the Internet, use e-mail, and install updates. Configuration
can be required.

When installing the Advanced edition into a network that has a Dynamic Host
Configuration Protocol (DHCP) server, additional configuration is
recommended for use with Xandros Server.

Configuring Internet and other connections

You can access the Internet and networks several ways:
* Ethernet network connection for local area network (LAN)
¢ Wireless LAN
* Connection to an Internet service provider (ISP) by:
* Telephone modem
* (Cable modem
* Digital Subscriber Line (DSL) modem
¢ Virtual private network (VPN)
If the computer is connected through Ethernet to a network with a DHCP

server, it is automatically configured by Xandros OS to access the network
and the Internet. In this case, you do not need to set up a connection account.
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Normally, the connection is configured automatically during installation and
you can skip this section. Configuration can be viewed in the Network
Connections panel of the Control Center (not documented here).

Setting up a connection

You can set up the following connections: cable, dial-up, DSL, LAN, wireless,
and VPN. A connection can be set to initiate automatically at login.

For a cable modem, you may or may not need to create a connection account.
Launch a Web browser and if you cannot connect, set up an account.

Because they are unlikely to be used for Xandros Server, dial-up, DSL, and
wireless setup are not outlined here.

You set up a connection account for a wireless connection, either in a LAN or
with access by Universal Mobile Telecommunications Service (UMTS /
GSM). UMTS is a successor to the Global System for Mobile communication
(GSM). UMTS is popular in Europe, while GSM is used in Europe and North
America. Because it is unlikely to be used for Xandros Server, configuration is
not outlined here.

To use a VPN connection, you need to have an account on a VPN server, and
you need to set up a connection account.

S (C s Connectionwizara =) w0

Xandros Connection Wizard

This wizard allows you to easily configure the method by which your system
will connect to a network such as the Internet.

Please select the type of connection:

Connection type:

Dial-up

Dial-up - AOL

GSM / 3G (UMTS) | HSDPA

DSL - Point-to-Point Over ATM

DSL - Point-to-Point Over Ethernet

Local Area Network

Local Area Network - Wireless

* | Local Area Network - [P Alias
Local Area Network - Virtual LAN >
Virtual Private Network - PPTP VPN E

Connection Wizard to configure an account for Internet access
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To set up a cable or LAN connection account

Click Launch » Applications » Internet » Connection Wizard. The
Connection Wizard launches. You can also access the wizard from the
Network Connections panel of the Control Center.

From the list, select the connection method:

Cable — To use a cable modem and a cable television line to connect to the
Internet, for example with speeds from 64 Kbps to 6 Mbps

Local Area Network — To use a local area network (LAN) to connect to
the Internet, for example using an Ethernet card

Local Area Network - IP Alias — A connection using a virtual network
interface. It is a feature of Linux that allows a single network device to
respond to multiple network settings, such as multiple IP addresses.
Usually you have a device such as eth0 that is configured with a specific IP
address. You can create a virtual interface eth0:1 on the same network card
that has a different IP address. For example, eth(O has an address of
192.16.0.1 and eth0:1 has an IP address of 10.0.0.1

Local Area Network - Virtual LAN — Independent networks in a physical
network. A local area network that maps computers by something other
than location, such as by department. When the Media Access Control
(MAC) address of a computer has been used for the mapping and the
computer is physically moved, the computer does not need to be
reconfigured.

Click Next.

For the IP Alias option, in the Select Connection Parent window, select the
network connection, then click Next.

If the Virtual LAN Identifier window appears, type a number to identify the
virtual network, then click Next.

If the Select Hardware window appears, the equipment detected for your
connection method is displayed. Select the hardware that you want to use
to connect, then click Next.

If the Select Address Type window appears, specify if a Static IP address is
to be used for the connection or if the IP address can change (Dynamic IP
address). Normally, a dynamic IP address is fine for Internet connections.

Click Next.
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1 If the Connection Settings window appears, provide the static IP address
and related network addresses. You can look up the addresses in the
Network Connections panel of the Control Center.

Connection Settings

Enter the static IP address and network mask for this connection,

P address: 192 . 168 . 1 . 224

Subnet mask: | 255 . 255 . 255 .

0
Gateway: 192 . 168 . 0 . [| (optional)
Setting a static IP address for an Internet connection

IP address — The static IP address of the computer when it connects to
the Internet. This address must be already be assigned by your network
administrator to your computer. View the addresses by entering
/sbin/ifconfig ina Linux console window.

Subnet mask — The subnetwork address of the computer, usually
255.255.255.0 or 255.255.0.0

Gateway — A gateway is a computer that connects networks to each other,
for example within a corporation or at the ISP for a home user. Firewall
servers and proxy servers are examples of gateways. A router is a
gateway; if yours has an IP address, enter it here. On a Linux computer,
you can view the gateway address by entering netstat -nr ina
console window. On a Xandros computer, it is viewable in the Network
Connections panel of the Control Center. On a Windows computer, enter
ipconfig /all

Click Next.

8 If the DNS Servers window appears and if your company has its own
Domain Name System (DNS) server(s), provide the IP addresses of these
servers. A DNS server translates character-based domain names, such as
xandros.com, into numeric IP addresses so that computers can recognize
them. You can look up the addresses in the Network Connections panel of
the Control Center.

You have the option of specifying a Windows Internet Naming Service
(WINS) server. A WINS server provides address resolution for Windows
computers, mapping computer names to IP addresses so that computers
can recognize them, similar to a DNS server. On a Xandros computer, it
can be viewed in the Network Connections panel of the Control Center. On
a Windows computer, it can be viewed in the Network Connections panel
of the Control Panel.

When done, click Next.

9 If the Enter Domain Names window appears, type the domain of the DNS
server, then click Add. An example is newyork.xandros.com. You add
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multiple entries so that they appear in order of priority, for example,
xandros.com, followed by newyork.xandros.com and xandros.ca

When you specify a host name, for example “myhost”, the networking
software adds the domain “xandros.com” to it to create a fully qualified
domain name, for example “myhost.xandros.com”. Using domain search
order you can specify domains and the order that the networking software
will try when looking up a host. For example, you specify in the Domain
Search Order box the domains “xandros.com”, “xandros.ca”, and
“xandros.net”. Typing “myhost” then causes the networking software to
try automatically (without configuration or definition elsewhere) using the
fully qualified names “myhost.xandros.com”, “myhost.xandros.ca”, and
then “myhost.xandros.net” until it finds a match. This domain search will
be done anywhere you type a host name, for example, if you enter
http://myhost in a Web browser, run a shell command like “ping myhost”,
or enter the host name in a mail program as the mail server name. This
feature is provided because it is common in large corporate networks to

use multiple domains.
When done, click Next.
(O (- Conmection Viard ) =l

Enter Domain Names

Enter the DNS server name for your network (optional), for example
my.company.com, and click Insert to add it to the domain search order.

-

~Domain Search Order

xandros.com
xandros.ca
xandros.net

[ < Back ][ Next > ]l Cancel

Specifying domain names

In the Connection Name window, type a name for the connection, such as
Office LAN or Cable Internet. Click Next.

In the Finish window, to initiate the connection each time the computer
starts up, enable the Connect automatically at system startup check box
(you will need to check the remember password box for this to work). To
connect after you finish the wizard, enable the Start this connection when
finished check box.

Click Finish to create the connection account.

To manually connect or disconnect, do so in the Network Connections
panel in the Control Center.
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To set up a VPN connection account

Click Launch » Applications » Internet » Connection Wizard. The
Connection Wizard launches.

From the list, select the connection method:

Virtual Private Network - PPTP VPN — To connect to the network
remotely, for example from a home computer to the office network. PPTP
refers to the Point-to-Point Tunnelling Protocol.

Click Next.

In the Select Connection window, specify the connection to use for VPN.
For example, you may have one connection account for DSL in order to
access the office computer and another connection account for personal
dial-up access. Click Next.

In the Server Settings window, type the name of the VPN server to
connect to in the Host name box, for example newyork.yourcompany.com,
which is the VPN server at the office. Or type the IP address of the VPN
server. Click Next.

In the Enter WINS Settings window, if you have a Windows Internet Name
Service (WINS) server, type its IP address, then click Next. A WINS
server maps computer names to IP addresses so that computers can
recognize them. If your computer is set to act as a WINS server, you do not
need to specify the WINS server IP address because Xandros
automatically detects it. For VPN purposes, if you want to use names when
doing Windows networking so as to avoid using IP addresses only, you can
enter the WINS server address here. Look up the WINS address in the
Network Connections panel of the Control Center, under Properties and
the WINS tab.

In the Login Settings window, provide the account name and password of
the user who will use the VPN access. If you intend to have it connect
automatically on startup, leave the Remember password check box
enabled. Then click Next.

In the Connection Name window, type a name for the connection account,
for example Work VPN. Click Next.

In the Finish window, to initiate the connection each time the computer
starts up, enable the Connect automatically at system startup check box
(you will need to check the remember password box for this to work). To
connect after you finish the wizard, enable the Start this connection when
finished check box.

Click Finish to create the connection account.

To manually connect or disconnect, do so in the Network Connections
panel in the Control Center.
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Setting up an e-mail account

Thunderbird Mail Client lets you use e-mail.

You need to know the following information:

Your e-mail user name, for example jane or bljr2q, and your password
Your e-mail address, for example jane@xandros.com

The types of incoming and outgoing mail servers, such as POP or IMAP
for incoming mail and SMTP for outgoing mail.

POP — E-mail messages are downloaded to your computer

IMAP — E-mail is on the server, which allows you to roam, for example
use a Web browser to access your mail from another computer. When using
a Scalix server, you specify IMAP, which means you can access groupware
functionality such as viewing free/busy times of colleagues in a Web
interface only.

SMTP — The standard server type for sending mail

The names of the incoming and outgoing mail servers, for example
pop3.company.com, smtp.xandros.com, or mail.example.net

You can enable Thunderbird Mail Client to use Lightweight Directory Access
Protocol (LDAP) service whereby address entries are automatically filled in
when you start typing in the To field of an e-mail message.

To set up an e-mail account for Thunderbird Mail Client

I
1

Click Launch » Applications » Internet » Thunderbird Mail Client.

You are prompted if you want to import settings and mail from other
applications. Enable an option, for example Don’t import anything, and
click Next. An Account Wizard is launched to allow you to set up a new e-
mail account. You can also add an account in Thunderbird Mail Client by
clicking Edit » Account Settings, then Add Account.

In the Account Wizard, with the Email account option enabled, click Next.
In the Identity window, complete the boxes:

Your Name — Type the name that you want to appear when you send an e-
mail

Email Address — Type your e-mail address, for example,
jane@xandros.com

Click Next.

For incoming e-mail, select the server type: POP or IMAP. Type the
address of the incoming mail server, for example pop3.company.com or
imap.company.com or 209.87.238.73
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Type the address of the outgoing mail server, for example
smtp2.company.com or 209.87.238.73. Then click Next.

Select the type of incoming server you are using.

® pop O |MAP

Select the type of incoming server you are using.

Enter the name of your incoming server (for example,
"mail.example.net"). O POP @ IMAP

Incoming Server: | popl.sympatico.ca

Enter the name of your incoming server (for example,

Uncheck this checkbox to store mail for this account in its own *mail example.net*).

directory. That will make this account appear as a top-level account
Otherwise, it will be part of the Local Folders Global Inbox account.

Incoming Server: ‘ scalixl.xandros.com

Use Global Inbox (store mail in Local Folders) Enter the name of your outgoing server (SMTP) (for example,

"smtp.example.net").

Enter the name of your outgoeing server (SMTP) (for example, Outgoing Server: ‘.scahxl.xandma‘cum

"smtp.example net").

Outgoing Server: | smtpl.sympatico.ca ‘

Configuring incoming POP (left) and IMAP (right) mail servers in Thunderbird Mail Client

For the Use Global Inbox option, leave it enabled if you want =@ vocal roiders
the account to appear as Local Folders. Disable it if you want et
to have the account appear above Local Folders with the A Drafte

account name you give it later in the wizard. & Trash

In the User Names window, type your user name in the box(es), for
example jane when your e-mail address is jane@xandros.com. Click Next.

In the Account Name window, type a name for the e-mail account as it will
appear in Thunderbird Mail Client, for example your name, then click
Next.

Click Finish. You are prompted if you want to set Thunderbird Mail Client
as the default e-mail application. You may then be prompted to enter your
password to access the incoming and outgoing mail servers.

You can download and install Thunderbird Mail Client in more
Ei] than 25 languages from www.mozilla.com.

To configure Thunderbird Mail Client to use LDAP

In Thunderbird Mail Client, select Edit » Account Settings. The Account
Settings window opens.

Click Composition & Addressing.

Enable the Use a different LDAP server option, and click Edit Directories.
The LDAP Directory Servers window opens.

Click Add. The Directory Server Properties window opens.
Set the following (example provided):
Name: Xandros LDAP

Hostname: smtpl
Base DN: ou=People, o=xandros

10
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Another entry for the base distinguished name (DN) can be c=]P, for
example, to include entries for Japan only.

6 Click OK. The Directory Server Properties window closes. Click OK again
to exit from the window.

1 Select your LDAP server from the list and click OK. The LDAP Directory
Servers window closes.

8 Click OK. The Account Settings window closes.

Installing updates and applications

In addition to the software provided during installation, updates and
applications for use with the Xandros desktop and Xandros Server can be
installed from Xandros Networks. Xandros Networks is an application that
accesses a Xandros server over the Internet so that you can install updates
and applications and delete applications. When your computer is being
managed by Xandros BridgeWays - Deployment and Management Edition,
Xandros Networks accesses your Xandros BridgeWays computer and for the
Shop section accesses a Xandros server.

For the Advanced edition, when you install using the following instructions,
you are installing to the Xandros Server computer, not into the software
repository.

As a minimum, Xandros recommends installing the updates because they
include critical patches and security updates.

An applet resides on the Panel that indicates when updates are available in
Xandros Network. By default you are notified when critical, security, and
recommended updates are available, and you can specify automatic
installation by day and time. A green check mark indicates that the computer
18 up-to-date. A red exclamation mark indicates that updates are available. For
computers managed by Xandros BridgeWays - Deployment and Management
Edition, it can also indicate that your system administrator is performing
updates.

Computer is up-to-date Updates are available

G o

Xandros update indicator

This section outlines how to install applications using Xandros Networks and
with the Xandros Update applet on the Panel. Also, if you have a proxy server,
configuration is required.

You can also perform updates in Xandros Management Console.
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To install updates and applications with Xandros Networks

| While connected to the Internet, click Launch » Xandros Networks, or
double-click the Xandros Networks icon on the desktop. Wait for the
database to load.

1 Click Application Updates, also clicking on + to expand the list. Or click
File » Install All Latest Updates from Xandros to get all updates.

S X andros NETWOTKS! .

File Edit Go Settings Help

& & ol Search i
- (V] J 4 = = | search ||
E]News B

® [Eshop App atio pdate
@ new Applications
8.1 Application Updates - i

[ Accessories = . .

[ Servers Critical Security Recommended New Service

2 Updates Updates Updates Drivers Pack

[ Utilities

@ installed Applications
Xandros Networks Client Update July 11, 2006

" This is a maintenance release that fixes several issues with the Xandros
Networks client application.

‘ Update Now
are liste es have bee alle:
Legend
Critical Updates Note

Critical updates are updates that resolve  Xandros does not guarantee or support .
problems with major fucntionality of the applications installed from sources other
¥andros Operating system or included than the Xandros distribution site.

[kl 1 [«]r]|programs. Applications installed from other sources |

KD

Administrator Mode Off

Xandros Networks for listing, updating, installing, and removing applications

3 Install the updates that you require, for example the general updates
shown at the Applications Updates level or updates at the application-
specific level.

4 Click File » Quit to exit Xandros Networks.

5 Normally new applications are automatically available from the
Applications menu immediately after installation, however log out then in
to ensure that the changes take effect. If you need to add any applications
to the Applications menu so that they appear there, use the Menu Editor
found under Launch » Applications » System.
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To install updates from the Panel

When connected to the Internet, click the Xandros update icon on the
Panel. A status window opens.

Click Check Now and install any updates identified.
The computer checks for updates at login by default. To change this, right-
click the icon on the Panel and select Configure Xandros Update. The

Automatically download... option needs to be selected from the drop-down
list in order to specify the day and time for automatically installing updates.

~ Update Options
Automatically download and install these updates: || »
HE @ critical
B @ security
H > Recommended
O ik other
%| Notify me when updates are installed
Update Frequenc
[gvery: Friday ~| at |12:00 am - ‘
Help Cancel

Specifying date and time for automatic updates

Configuring proxy server settings for Xandros Networks and Internet

If you use a proxy server that requires a password when connecting to
external networks, such as to the Internet or Xandros Networks, and you are
required to log in each time you access the Internet, you may need to
configure the proxy settings so that files download properly and to avoid
logging in each time. After installing Xandros OS and configuring your
Internet connection, follow the procedure outlined here.

To configure proxy settings

vl W N —

Click Launch » Control Center » Control Center.

Click File Manager, then Web Browser, then Proxy.
Enable the Manually specify the proxy settings check hox.
Click the associated Setup button.

In the HTTP box, type http:// followed by your user name, a colon,
your password, the @ symbol, and the IP address or host name of the
proxy server. An example of the format is
http://username:password@192.168.6.3

Click OK to exit from the window.

Click Apply. Some applications, such as Firefox Web browser have their
own configuration, so you may need to change them too.

Configuring Xandros Server B3



Configuring a DHCP server

If you installed the Advanced edition into a network that uses DHCP and you
intend to use DHCP to deploy jobs to Xandros Desktop and other computers,
the DHCP server can have additional configuration. The DHCP server can be
Windows or Linux/UNIX-based, and configuration is recommended before any
jobs are deployed. If your network does not use DHCP or you will specify
which Community Management Server to use for the deployment, skip this

section.

Configuring 2 Windows DHCP server

You can determine if the Windows server is a DHCP server and configure it
for the Xandros Server computer with the instructions here for Windows

Server 2000 and 2003.
-Ioix
File Action View Help
o |BmER 2
_[Q DHCP Server Options
=] @ 2003server? mixed2003,com [172,16.3.12] Option Name | endar | value
=] Seope [192,168.0.0] Scopet &) 006 DS Servers Standard 192.166.0.1
+-{[7) Address Pool
g s 21
Reservations
(% Scope Options General | tdvanced |
@ Server Options
Auwailsble Options | Description :l
O 041 NIS Servers Addresses o
[ 042 NTP Servers Addhesses ©
043 Vendor 5pecific Info Embedded +
[ 044 WINSMBNS Servers MENS Addn -
| | r
i~ Data entr
Data: Binary: ASCII:
O0oon 00 78 44 4D 53 62 6F 6F . =DHShoo
0008 74 3D 78 61 €E 73 65 72 t=sanser
0010 76 65 72 34 2F &F 70 74 wver: -opt
0018 2F 6C 69 76 65 20 78 44 ~liwe =D
0020 4D 53 6C 64 61 70 3D 31 MHSldap=1
0028 3% 32 ZE 31 36 38 2E 31 92.168.1
0030 ZE 33 .3
Ok I Cancel I Apply | J
»

Configuring a Windows DHCP server (Windows Server 2003 shown)
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To configure a Windows DHCP server for deployments

At the Windows DHCP server, click Start » Programs » Administrative
Tools » DHCP. A DHCP windows launches. If it does not, there is no
DHCP server and you skip the rest of this procedure.

Ensure that the DHCP server is authorized, for example as the top-level
administrator, right click the server entry on the left side and select
Authorize.

Now configure it. Click the Scope folder, then the Scope Options folder.

Right-click in the right pane and select Configure Options. A Server
Options window opens.

In the General tab, enable the 043 Vendor Specific Info check box, then
enter the following string into the Data entry box to encode to binary:

xDMSboot=xanserver: /opt/live xDMSldap=192.168.1.3

where “xanserver” is the name of your Xandros Server and a DNS entry
pointing to one or more repository servers. This DNS entry needs to be
created by your network administrator. The IP address is for the computer

that you installed Xandros Server on and is also the IP address provided for
the xDMSIdap setting. Replace the IP address of 192.168.1.3 with yours.

Click OK to apply the settings and exit from the window. The server is
now configured to Xandros Server vendor-specific options.

To verify correct server configuration, perform the following tasks at a
computer other than the DHCP server:

¢ Boot the Xandros Server installation media, such as the CD.
*  Quickly enter menu at the prompt.

*  Quickly select Rescue Console from the menu.

» After bootup, enter cat /etc/vendor info

*  Check that the resulting code contains the original encoded line (the
line in step 5). If so, the DHCP server is configured properly.
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Configuring a Linux DHCP server

This server is not the Xandros Server computer. It is the DHCP server that
provides DHCP service in the network in which the Xandros Server
computer was installed.

You will generate a configuration line with the format
xDMSboot=hostname: /opt/live xDMSldap=0.0.0.0
An example is

xDMSboot=xanserver: /opt/live xDMS1dap=10.0.0.5

where “xanserver” is the name of your Xandros Server and is the DNS name,
and 10.0.0.5 is the IP address of your Xandros Server computer. The
hostname is a DNS entry pointing to one or more repository servers. The IP
address is for the computer on which Xandros Server is installed and is the IP
address provided for the xDMSIdap setting. The code needs to be encoded in
hex for a Linux DHCP server using the following instructions.

To determine if DHCP is being used
* On a Debian-based server, open a console window and enter
dpkg -1 | grep dhcp

If the server is a DHCP server, the response indicates this, for example

ii dhcp-server 3.0pll.2-12 DHCP Server
or
ii dhcp3-server 3.0.4-13 DHCP server for...

Or, on an RPM Package Manager (RPM)-based server, such as Red Hat or
Novell, open a console window and enter

rpm -ga | grep dhep

To configure a Xandros DHCP Server for deployments

| If you use another Xandros Server for DHCP service, access the DHCP
Server component at that computer.

1 Access the Server Options window.

3 Right-click in the main window and select Add Option. The Add New
Option window opens.

4 Select Xandros Default from the Vendor drop-down list.

5 Select Xandros BridgeWays - Deployment and Management Edition from
the Option drop-down list.
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Complete the fields:

DME LDAP IP address — The IP address of the Xandros Server -
Advanced Edition computer, for example 192.16.1.3

DME Boot — The IP address or the host name of the Xandros Server -
Advanced Edition computer, for example 192.16.1.3 or
xanserverl.ottawa.xandros.ca If you specify a name, it must be resolvable
in DNS.

Click Add to add the option, then close the window when it reappears to
add more options.

So in this example, the configuration line
xDMSboot=hostname: /opt/live xDMS1ldap=0.0.0.0
automatically becomes

xDMSboot=xanserverl:/opt/live xDMSldap=192.16.1.3

To configure a Linux DHCP server for deployments

Log in as Administrator and open a console window, or open a console
window as Administrator by clicking Launch » Applications » System »
Administrator Tools » Console.

Enter the appropriate command in the following format:

echo -n "xDMSboot=xanserver:/opt/live xDMSldap=10.0.0.5" | hexdump -C

where “xanserver” has a valid DNS entry of 10.0.0.5.

The output of the command is similar to the following:

00000000 78 44 4d 53 62 6f 6f 74 3d 78 61 6e¢ 73 736572  |xDMSboot=xanserver:/o|
00000010 76 65 72 3a 2f 6f 70 74 2f 6¢ 69 76 6520 78 44 | pt/live xDMSldap |

00000020 4d 53 6¢ 64 61 70 3d 31 30 2e 30 2e 30 2e 35 | =10.0.0.5|

If a DHCP2 server is being used, add these configuration lines to the global
section of the dhcp.conf file:

option vendor-encapsulated-options
78:44:4d:53:62:6f:6£:74:3d:78:61:6€:73:73:65:72:76:65:72:

3a:2f:6£:70:74:2f:6Cc:69:76:65:20:78:44:4d:53:6C:64:61:70:
3d:31:30:2e:30:2e:30:2e:35;

where the hex values are the ones generated in the previous step and each
pair is separated by a colon (:) and a semi-colon (;) is placed at the end of
the line. The line is one line, not three as shown.

If a DHCP3 server is being used, you can configure the server to provide
this information only to computers that specifically request it, such as
Xandros computers (optional).
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class "xDMSclient" {

match if substring (option vendor-class-identifier, O,
10) = "xDMSclient";

option vendor-encapsulated-options
78:44:4d:53:62:6f:6£:74:3d:78:61:6€:73:73:65:72:76:65:72:
3a:2f:6£:70:74:2£:6C:69:76:65:20:78:44:4d:53:6Cc:64:61:70:
3d:31:30:2e:30:2e:30:2e:35;

}

where the “option vendor-encapsulated-options” line is the same as for
DHCP2.

5 To verify correct server configuration, perform the following tasks at a
computer other than the DHCP server:

¢ Boot the Xandros Server installation media, such as the CD.
*  Quickly enter menu at the prompt.

*  Quickly select Rescue Console from the menu.

» After bootup, enter cat /etc/vendor_ info

*  Check that the resulting code contains the original encoded line (the
echo line in step 2). If so, the DHCP server is configured properly.
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Other post-installation tasks 6

This chapter outlines how to:

* Install from an Applications CD or Installation CD, including Scalix
Xandros Edition

* Install Xandros Management Console (xMC) on a Windows computer
* Move the private key offline

* Restore Xandros Server

¢ Uninstall Xandros Server

Installing from an Applications CD or Installation (D

Insert the CD and follow the prompts. Otherwise, manual instructions are
provided here for reference.

Depending on the edition of Xandros Server purchased, Scalix Xandros
Edition is provided on a separate CD.

Information specific to the Applications CDs is found in the Xandros
Management Console Administrator Guide, for example about installing the
BRU agent to back up a computer or installing Xandros Management Console
on a Windows computer.
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To install Scalix Xandros Edition

* After logging in to the desktop, insert Applications CD 2 in a drive, wait for
the installation panel, then install it. Scalix Xandros Edition needs to be
installed onto a 32 bit version of Xandros Server. After installation, the
component appears in xMC.

To view and install packages from an Applications CD or Installation CD (manual method)

| Insert the CD in a drive. An installer window opens, but because we are
using the manual method to install, close it.

1 Click Launch » Xandros Networks. You do not need an Internet
connection.

3 Click Edit » Set Application Sources.

4 Note which boxes are enabled so that you can restore these later. The
default is the Xandros distribution site.

5 Enable the CD-ROM drive 1 or CD-ROM drive 2 check box, depending on
the drive in which you inserted the CD. Disable all other check boxes.

6 Click OK and provide the Administrator password if prompted. The
applications database is compiled.

1 Click New Applications, clicking on the + to expand the list. View or select
the packages for installation by enabling the check boxes. You can select
multiple packages. If you perform a search for an application and do not
find it, try clicking Expert in the left pane. You can also change the mode of
the window by clicking Settings » Expert View.

8 Install a single package by clicking Install or multiple packages by clicking
File » Install Selected Applications, then click OK to install. Wait while the
packages are being installed, respond to any prompts, then Close the
installation window when done.

9 Click Edit » Set Application Sources and reset the source (for example,
enable only the Xandros distribution site check box).

[0 Applications installed from the CD normally appear in the appropriate area
of the Launch menu. Some applications run in the background and are not
launched. Any Xandros Server components are found in Xandros
Management Console.
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Installing Xandros Management Console on a Windows computer
xMC can be installed from Xandros Server Applications CD 1.

xMC can be installed on a computer with Windows XP with Service Pack 2 or
Windows Vista. Both Home and Professional editions of Windows XP are
supported. xMC is also known to run on Windows XP with Service Pack 1, but
this is not officially supported.

The installation is referenced to a Community Management Server, which can
be a Xandros Server or Xandros BridgeWays installation. The Remote xMC
Service component needs to be installed only on the Community
Management Server because that computer controls access to the Managed
Community. Because you are identifying the Community Management Server
by Internet Protocol (IP) address, use a server that has a static IP address.

Installation can take 15 minutes.

When running xXMC on a Windows Vista computer for the first time, the User
Account Control needs to be turned off.

To use the Web-based interface of the xMC Helix Server component, Firefox
Web browser also needs to be installed on the Windows computer.

To check Windows XP if Service Pack 2 is installed

¢ At the Windows computer, click Start » Control Panel and access the
System panel. When Service Pack 2 is installed, it is shown as such. If you
have Service Pack 1, xMC is known to install on it, but this is not officially
supported. You can install with Service Pack 1 or go to the Microsoft Web
site and update to Service Pack 2.

System Properties 7 x|

System Restore | Automatic Updates | Remote |
[Geed | CompuerMame | Hardware |  Advanced |

System.
Microsaft Windows XP
Home Edition

'l j Version 2002
IJ/ 1 Service Pack 2

Registersd to:
 — Davs

Viewing that Service Pack 2 is installed on a Windows XP computer
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To install xMC on a Windows computer (Windows XP example)

| Obtain the IP address of the Xandros Server computer. Version 2 is
supported. You want the IP address of the Community Management
Server. Look for it in the Managed Community component of xMC
(shown) or the Network Connections panel of the Control Center.

]

A Xandros MaEnagement Console s Xanserven. ottawa.-xandros.ca)

File Wiew Tasks Bookmarks Windows Help

Computer name: I_ﬂ xanserverl.ottawaxandros.ca

>t xoBus?

© ¥ Managed Community Name + Description
§IManagement Licenses @ xanserverl.ottawa .xandros.ca 172.16.1.224
| All Computers § xanserver2 ottawa xandros.ca 172.16.1.225

& § xanserverl.ottawa xandros.ca
@ Local Accounts

Viewing the IP address of a Xandros server

1 At the Windows computer, close any applications that are open.

3 Insert Xandros Server Applications CD 1 into a drive. Ignore any error
message.

4 The wizard launches automatically. If it does not, open a My Computer
window, right-click the CD entry, select Explore, then navigate into the
\Windows\xMC folder, and double-click the xXMC-Install.msi file.

5 Complete the wizard. Selecting a Complete installation also installs
documentation. It can take several minutes for the application to install, for
example 10 minutes.

i5' Xandros Management Console Setup 1= x|

Welcome to the Xandros Management
Console Setup Wizard

The Setup Wizard wil instal Xandros Management Console
on your computer. Click Next to continue or Cancel to exit
the Setup Wizard.

75 Xandros Management Console Setup

Community Management Server

Enter the Community Management Server connection information.

Name or 1P address:

172.16.1.224

Bay

Installing xMC on 2 Windows computer

6 To use the Helix Server component, also install Firefox Web browser from
www.firefox.com
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To run xMC on a Windows Vista computer

* After installing xMC, the User Account Control needs to be turned off
before running xMC for the first time only. Access the Control Panel, then
User Accounts and Family Safety, then User Accounts, and Turn User
Account Control on or off.

Moving the private key

To prevent unauthorized access to secure system resources through the
Xandros Server software, its administrative software uses Secure Sockets
Layer (SSL X.509) certificates to validate authenticity. Part of the certificate
infrastructure is a public/private key pair, where the private key is used to
create a certificate and the public key is used to validate it.

The private key used in this process is kept secure and accessible by the
desktop Administrator at the Community Management Server. The key is
stored in a key file and must be available on the Xandros Server computer
when a new certificate is generated, which is limited to when the name or IP
address of the Xandros Server computer is changed or re-installation.
Otherwise the key file can be saved to an offline medium, such as a floppy
disk, and removed from the hard disk of the Xandros Server computer.

If you choose to move the key offline, you do so immediately after installation,
not after you add administrator accounts for Xandros Server components.

A

Some processes can stop functioning if a certificate needs to be
regenerated but it has been moved offline.

Eile Edit View Go Bookmarks Window Tools Help

(R R R R

®

4

1 object(s)

dev

disks

etc

home
initrd

lib
lost+found

4KB

04/03/07 06:17 am

Size:
4KB (4,096 bytes)

Write all to disc...

Add all to disc project...

Address € | /opt/xandros/sharefxdms-ca M
o1 20" BR G DNT
All Folders x|\
A My Linux
A My Home xDMS-CA
= [ All File Systems xdms-ca
=l Directory
bin
boot Modified:

B This Computer

A

Private key folder
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To move the private key

| Open the Xandros File Manager with administrator privileges by clicking
Launch » Applications » System » Administrator Tools » Xandros File
Manager. If prompted, enter the password used to log in to the desktop as
Administrator.

N

Navigate to /opt/xandros/share/xdms-ca/
Select the xXDMS-CA folder.
To copy to a floppy disk, open a second Xandros File Manager window as

Administrator, access the Floppy disk, then drag and drop the folder so that
it is copied onto the floppy disk.

S w

To copy to a CD, open a second Xandros File Manager window as
Administrator, access the DVD Writer, click Create data disc, then drag and
drop the folder.

5 Verify that the folder has been successfully copied.

6 Delete the file cakey.pem from the original
/opt/xandros/share/xdms-ca/xDMS-CA/private folder.

To restore the private key

* Restoring the private key is a similar series of steps, except that the folder
must be copied from the offline medium to /opt/xandros/share/xdms-ca/
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Restoring Xandros Server

If you cannot log in or there is a problem with the black Xandros startup
screen, you can restore the installation.

Xandros OS includes a troubleshooting menu that lets you restore Xandros
Server, for example in the event of a crash or if you need to repair it after
installing another operating system, for example to restore the black Xandros
startup screen. User accounts and user folders are preserved. Restoration is
performed at the partition level, meaning you select the partition to fix. For
example, if you have Xandros Desktop installed on one partition and Xandros
Server installed on another partition, you select the partition to restore. In
such a scenario, you first need to determine the partition number.

The easiest way to determine the partition number is to start the installation
wizard with the Xandros installation CD. Enable the Replace existing Xandros
OS option, view the partition, then Cancel the installation. You can also use
the procedure outlined here.

To determine the partition number
| Click Launch » Find » Files/Folders.
1 In the Named field, type

grub.conf
3 Select the file:/ folder from the Look in drop-down list.
4 Click Find.

5 Double-click a grub.conf file. There can be more than one such file, and it
does not matter which one you open.

6 Look for the Xandros Server installation.

1 Look for the “root” line associated with it. Note the partition number. In

the example shown, hdb2 refers to partition 2 on the second hard disk
(“b”).

) ¢ menu.lst - Text Editor |_R20x]
File Edit View Bookmarks Tools Settings Help
N ¥ v e o )| @)
= EHE =0 g m I AR RS

Xandros Server title- Xandros Server 2 Standard virtualization
. root (0x81,1)
kernel /boot/xen-3.0.3-1-1386.9z console=ttyS0, 115200 domO_mem=196000
module /boot/vmlinuz-2.6.18-dcc-xen quiet rw acpi=on
“resume2=swap:/dev/hdbl  root=/dev/hdb2
module /boot/image-2.6.18-dcc-xen.img

hdb2 is Partition 2

title Safe Vvideo Mode Virtualization
root (ox81,1)
kernel /boot/xen-3.0.3-1-1386.9z console=ttyS0,115200 domO_mem=196000
module /boot/vmlinuz-2.6.18-dcc-xen 3 quiet rw acpi=on
resume2=swap: /dev/hdbl  root=/dev/hdb2
module /boot/image-2.6.18-dcc-xen.1img

title Configure (Expert) Virtualization
. root (0x81,1)
Line: 1 Col: 1 INS NORM

KD

Determining partitions on hard disk
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To restore Xandros Server
| Place the Xandros Server Installation CD in the drive.
1 Restart your computer.

3 When a message appears to press <SPACE> or type “menu” for
troubleshooting options, do so immediately, and press Enter. Accessing the
menu is successful when a Xandros selection screen appears that includes
Restore Xandros as an option.

4 Using the down arrow, I, select Restore Xandros, and press Enter.
Hardware is detected.

5 Viewing the left side of the list that appears, type the Number of the
partition that you want to restore (use the previous procedure to
determine the partition number), and press Enter. You are prompted to
confirm the restoration, so indicate yes. When prompted if you want to
change the command line, indicate no. When prompted if you want to
change the boot device, indicate no. The installation is restored and your
files and some settings are saved.

Uninstalling Xandros Server

Xandros Server and all associated applications can be removed from the
computer. Uninstalling it from a disk or partition also removes your files and
data in that disk or partition, and if Xandros OS is the only operating system
installed then the computer will not start up after removal. Xandros Server is
uninstalled using the Installation CD. It can also be uninstalled using the fdisk
procedure in a console window (not documented here).

There is no automatic uninstall feature. Use the following
A procedures at your own risk.

To uninstall Xandros Server using the Installation CD

| Back up any files that you want to keep to another disk, partition, or
external media, such as a CD.
1 Remove all media from drives, including floppy disks, CD, and tapes.

3 If you have Xandros Server installed on a partitioned disk (meaning the
entire disk is not used for Xandros Server or there is another operating
system installed on the same disk), you need to determine which partition
to erase. See “To determine the partition number” on page 85.

4 Insert the Xandros Server Installation CD into the drive.

5 Restart your computer, and wait for the Xandros Installation Wizard. If you
need help reaching the wizard, see “Troubleshooting installation” on
page 48.

6 Inthe wizard welcome window, click Next.
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Enable the I accept this agreement option, and click Next.
Type the serial number, and click Next.

In the software selection window, click Next.

Enable the Manage disks and partitions option, and click Next.

Select the disk or partition to erase. For example, hdab refers to partition 5
on the first hard disk. Then click Delete, and confirm the deletion.

If the Xandros Server installation is the only operating system using the
swap partition, you also need to uninstall the swap partition. Select the
swap partition (indicated by Linux - swap in the File System column), and
click Delete.

Save the changes by clicking Write and confirming the write. Wait for the
partition table to be written.

Uninstalling Xandros Server deletes all files on the partition or
disk where it resides. If the Xandros OS installation being
deleted is the only operating system installed, the computer
will not start up after uninstallation.

Click Cancel and exit the wizard. Xandros Server has been uninstalled.

If required, remove the Xandros startup screen using one of the following
procedures.

To remove Xandros boot loader from a Windows XP computer

0O ~N o~ U N W N —

Insert the Windows XP CD into the drive.

Restart your computer.

Press R for Repair on the Welcome to Setup window.
Select the Windows installation you want to log in to.
Type the Administrator password, and press Enter.
Type fixmbr and press Enter.

Confirm that you want to write a new MBR.

Restart the computer.

To remove Xandros boot loader from a Windows 9x computer

Launch the MS-DOS prompt by clicking Start » Applications »
Accessories and selecting this option.

At the command prompt, type f£disk /mbr and press Enter.
Restart the computer.
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To remove Xandros boot loader using Xandros 0S
| Log in as Administrator.
1 Ina console window, type
etcdevset -S -c boot.main -t mbr -v no
and press Enter. This command is not necessary to remove the Xandros

boot loader if Xandros was the only operating system installed because you
are unable to log in as Administrator.

To remove Xandros boot loader from a Linux computer
| Restart the computer.

1 When the Xandros startup screen appears, select the other Linux
operating system.

3 Start up and log in to the desktop.

4 Open a console window as Administrator (root) and enter grub or 1ilo
depending on which boot loader method the Linux operating system uses.
With the grub command, for example, pressing Tab can bring up a list of
commands that will allow the non-Xandros boot loader to be restored. If
the command does not work, you may need to perform a repair or rescue
using the Linux operating system installation CD.
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